VanDyke Software Forums

Go Back   VanDyke Software Forums > SecureCRT 5.2/SecureFX 4.0 Beta
User Name
Password
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Rate Thread Display Modes
  #1  
Old 09-07-2006, 03:11 PM
forrie forrie is offline
Registered User
 
Join Date: Sep 2006
Posts: 4
Linux Terminal Emulation...

Hi everyone.

I recently opened a ticket with support, regarding some issues I'm having with Linux support emulation.

The problem has to do with, regardless of the LANG=en_US and TERM=Linux or whatever, when you pop up a dialog menu like "ntsysv" the characters are always garbled and/or will show the +---------+ within the colored borders.

Furthermore, when you scroll through an options list, the screen gets all garbled up and is nearly unintelligible.

I'm wondering about other's experience with this - and what observations you've see. More feedback to support will give them a better idea of how to resolve this problem.

For me, it's become a big pain, since my company is now deploying a LOT of linux systems, and I need to access these remotely.

It's worth noting that the same problem occurs if you ssh to another linux system (from the console, not SecureCRT) and bring up a similar dialog/application. Maybe a connection there?

The versions of Linux I'm using are CentOS-4.3 and Redhat AS 4 (Nahant).

Thanks!
  #2  
Old 09-08-2006, 12:15 AM
toloughlin's Avatar
toloughlin toloughlin is offline
Senior Member
 
Join Date: Feb 2004
Location: Nashua, NH
Posts: 377
I think I may know the issue ....

I'm using RHEL3 AS ... Linux Emulation / ANSI Color.

In 'env' does it show you emulating as 'linux'?
The other thing - your LANG.

When the Emulation set to DEFAULT in SecureCRT & you have something like: LANG=en_US.UTF-8 in Linux .. it will screw everything up.

I actually just replicated it for you ... see the attached image.

If all else fails, start using 'chkconfig' in Red Hat ... open a bunch of tabs, use the chat window & send 'chkconfig --level 345 sshd off' to all ... wham - all the Red Hat boxes have sshd off for levels 3, 4 & 5

Does this help? Good luck!
Attached Images
File Type: jpg garble_screen.jpg (157.6 KB, 973 views)
__________________
----------------------------------------------
Tom O'Loughlin

Last edited by toloughlin; 09-08-2006 at 12:17 AM.
  #3  
Old 09-08-2006, 01:57 PM
forrie forrie is offline
Registered User
 
Join Date: Sep 2006
Posts: 4
I did this with the support rep, changing the vars, etc.

We managed to get the screen to print, with color, the +----+ lines... but when you go to scroll, the same garbled problem occurs.


_F
  #4  
Old 09-08-2006, 03:12 PM
toloughlin's Avatar
toloughlin toloughlin is offline
Senior Member
 
Join Date: Feb 2004
Location: Nashua, NH
Posts: 377
Are you making an intermediate hop between where you are ending up?

For example, to access Node B:
SecureCRT - ssh to A - ssh from A to B?

What does your env tell you? what if you:
TERM=linux ; export TERM
__________________
----------------------------------------------
Tom O'Loughlin
  #5  
Old 09-09-2006, 04:41 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Hi Forrie,

I tested the same program (ntsysv) using ANSI emulation and it looked great. Have you tried ANSI emulation?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
  #6  
Old 09-11-2006, 12:32 PM
forrie forrie is offline
Registered User
 
Join Date: Sep 2006
Posts: 4
I changed my LANG=en_US and terminal emulation to ANSI and it does look better, though we still have th odd character interpretations (see below).

How does this differ from Linux emulation, and is it possible to fix this eventually.

The way I would expect to see it is the colors, minus the 旼컴컴컴 etc. etc.


Thanks.



컴컴컴컴컴캑 Services 쳐컴컴컴컴컴컴컴컴컴

What services should be automatically started?

[ ] acpid
[ ] anacron #
[ ] apmd
[ ] atd
[ ] auditd
[*] autofs
[ ] bluetooth
[ ] chargen

旼컴커 旼컴컴컴커
Ok Cancel
읕컴켸 읕컴컴컴켸


읕컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴컴
  #7  
Old 09-11-2006, 01:17 PM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
I used LANG=he_IL.UTF-8 with ANSI emulation.

Does the attached image look like what you're wanting to see?
Attached Images
File Type: jpg ntsysv-scrt.jpg (59.5 KB, 1440 views)
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:12 PM.


copyright 1995-2017 VanDyke Software, Inc.