Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 07-17-2019, 10:22 AM
mrjoli021 mrjoli021 is offline
Registered User
 
Join Date: Jul 2019
Posts: 6
text truncated

I am running securecrt on MAC (not that this makes a difference). I use to to connect to multiple Linux/Unix boxes. When I run some command that is longer than my window size the rest of the text gets truncated. How can I change it to either wrap around like in my regular MAC terminal or autoresize to fit it all in there.

for example if I tail a log file with a long error message I will only get a piece of the message per line not the entire message.
Reply With Quote
  #2  
Old 07-17-2019, 10:56 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 211
Hi mrjoli021,

I am sorry to hear that the output of your commands are being truncated in the SecureCRT window!

Since the commands seem to execute without an issue we can assume that SecureCRT is sending the commands to the remote correctly. The data displayed in the SecureCRT terminal window is actually being sent by the remote.

Does the behavior occur if you connect to the same remote host(s) and run the same command(s) using a different terminal emulator, or just when you connect with SecureCRT?

Are the truncated lines all the same length? Would it be possible for you to provide a screenshot depicting the issue?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 07-17-2019, 11:50 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 211
mrjoli021,

Also, what version of SecureCRT are you running on your MAC?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #4  
Old 07-17-2019, 03:11 PM
mrjoli021 mrjoli021 is offline
Registered User
 
Join Date: Jul 2019
Posts: 6
I am running 8.5.4 build 1942. This happens on all linux boxes I connect to using only secureCRT. On any other terminal it works fine. I have used a vm running windows putty to the same linux box as well as the standard Mac terminal and both seem to wrap around without any issues. And again it happens on multiple boxes not just one Linux box.

not sure how to get secureCRT behave the same.
Reply With Quote
  #5  
Old 07-17-2019, 03:19 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 211
Hi mrjoli021,

What terminal emulation type do you have set for these sessions? (Options -> Session Options -> Terminal -> Emulation)

If the "Terminal" drop-down is not set to Xterm, please change it to Xterm and then re-test.

What are your results?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 07-17-2019, 04:58 PM
mrjoli021 mrjoli021 is offline
Registered User
 
Join Date: Jul 2019
Posts: 6
When I change it to xterm my color scheme changes and now vim does not show up with color. How can I fix this now?
Reply With Quote
  #7  
Old 07-17-2019, 05:00 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 211
mrjoli021,

Yes, please change the emulation type to Xterm and then disconnect and then reconnect your session.

What are your results?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #8  
Old 07-17-2019, 05:05 PM
mrjoli021 mrjoli021 is offline
Registered User
 
Join Date: Jul 2019
Posts: 6
got it working. I think I am good now.

thanks
Reply With Quote
  #9  
Old 07-17-2019, 05:08 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 211
mrjoli021,

Great! I am glad to hear that changing the emulation type to Xterm did the trick! Have a wonderful rest of your day!
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:05 AM.