Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 03-01-2021, 05:42 PM
lenka lenka is offline
Registered User
 
Join Date: Mar 2021
Posts: 1
VCP command failure

I am trying to send userid and password as parameters using user's input to vcp command. Somehow it is not making connection to the server. This problem started after we upgrade secureCRT to 8.5 version.These command never had any problems in the past. Can you please help?

Here are the commands
Code:
cls
set /p uid=Enter Userid:

echo %uid%
cls
set /p pwd=Enter Password:

echo %pwd%


setlocal EnableDelayedExpansion
cls
echo Copying file to X: drive...

vcp -auth password -preserve -pw %pwd% %uid%@xxxxx.yy.zz.com:/folder3/%uid%/folder2/folder1/file1.* C:\localfolder\  || goto error

Last edited by cboyack; 03-02-2021 at 09:44 AM. Reason: Please use [CODE] and [/CODE] tags to denote areas of code
Reply With Quote
  #2  
Old 03-02-2021, 09:43 AM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 110
Hi lenka,

The only real way to get a better look at what's going on behind the scenes is to obtain a debug log of the interaction.

Adding -v -v -v to the command will increase the logging level of the command, but such information has the potential to include sensitive information such as passwords, and in general, should not be posted to public forums such as this one.

As such, would you mind adding both -v -v -v as well as introduce a logging component (--log logfilepath.txt) to the beginning of your VCP command line arguments and then attempt to run the process again?

Your final line might look something like this:
vcp -v -v -v --log logfilepath.txt -auth password -preserve -pw %pwd% %uid%@xxxxx.yy.zz.com:/folder3/%uid%/folder2/folder1/file1.* C:\localfolder\ || goto error
Please inspect the log file generated for further clues as to why the connection might be failing.

If you are in need of further assistance after generating and inspecting the log information, it would not be appropriate to post potentially sensitive information to these forums, so could you please attach the resulting log file to an email message to support@vandyke.com? Please include Attn Cameron: Forum Thread #14448 in the subject line.
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by cboyack; 03-02-2021 at 09:45 AM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:45 AM.