Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 12-16-2015, 05:09 AM
umbongo umbongo is offline
Registered User
 
Join Date: Oct 2015
Posts: 13
Issues with remote accepting password in vbScript

Hi,

I have recently started having inconsistent problem with passwords on some remote devices using a script that I have been using for some time. I'm not sure if the problem is with the authentication server, authentication client or the way the password is being supplied and so far my troubleshooting efforts have not found the root cause. The output on screen shows a password (supposedly, as it is not asking me to change my password as would happen if it was blank) being entered and authentication failing. The failed passwords are not consistent across devices. I have a list of devices to try and it fails randomly on different devices every time. If I manually log in it works every time and the logs on the far end device just show a failed login attempt when the script fails.


Here's what I have tried so far:
I have tried switching on raw logging to see if I can see exactly what way the password is being entered, but unfortunately that reveals nothing as the password is still not displayed.
I have output the value of the password variable to the user to ensure it shows what is expected, and it does.
I have also introduced a 500ms delay between the password being sent and the return key in case SecureCRT was being too fast entering it, but again it has made no difference.
FYI, synchronous is set to true and I have code handling different WaitForStrings.

Question: Can someone offer some suggestions how to troubleshoot this issue further?

(I don't have root permission to enable me to run tcpdump)


7.2.3 (x64 build 500)

Thanks!

Last edited by umbongo; 12-16-2015 at 07:27 AM. Reason: Additional info
Reply With Quote
  #2  
Old 12-16-2015, 08:28 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,050
Hi umbongo,

I would feel more comfortable trying to troubleshoot a password issue via email instead of in the public forums.

Please send an email to support@vandyke.com and reference "Attn Brenda - Forum Thread #12189" in the subject line.

Please include what OS/platform you are running SecureCRT on.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
vbscript


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:14 PM.