Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-12-2013, 03:17 AM
ACX's Avatar
ACX ACX is offline
Registered User
 
Join Date: Jan 2013
Posts: 3
Ctrl-w

Hello,
I have problems with the ctrl-w command to delete the last word before cursor (in BASH - Emacs mode).
The other ctrl shortcuts work as expected :
ctrl-a : Move cursor to beginning of line
ctrl-e : Move cursor to end of line
ctrl-u : Cut everything before the cursor
ctrl-k : Cut everything after the cursor
ctrl-y : Paste the last thing to be cut
ctrl-_ : Undo

I'm using SecureCRT 7.0.2 on Mac OS X 10.8.2
Reply With Quote
  #2  
Old 01-14-2013, 09:56 AM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
Greetings ACX,

Thanks for posting your question/issue. I tested SecureCRT 7.0.2 on OS X 10.8.2 and Ctrl-W works for me, so I'm pretty sure the issue you're seeing isn't a bug with SecureCRT.

Can you connect to the server, run stty -a, and let me know what you see?
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
  #3  
Old 04-05-2013, 07:40 PM
ACX's Avatar
ACX ACX is offline
Registered User
 
Join Date: Jan 2013
Posts: 3
Hi, i'im now using 7.1 beta 3 to see if if was fixed.

This is the result:

[root@w2 ~]# stty -a
speed 38400 baud; rows 55; columns 115; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q;
stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts -cdtrdsr
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke
Reply With Quote
  #4  
Old 04-08-2013, 10:43 AM
miked's Avatar
miked miked is offline
Registered User
 
Join Date: Feb 2004
Posts: 2,040
ACX,

I tested SecureCRT 7.1.0 on OS X 10.8.3 and Ctrl-W works for me, connected to a remote Linux server running bash, so I don't think the problem is a bug in SecureCRT.

Your server setting looks like it should: werase = ^W, so I don't think the problem is with the remote settings.

Can you look through the keyboard shortcuts defined in System Preferences and look for ^W in each of the categories (Application Shortcuts, etc.)?

As a workaround do you want to try mapping a key in SecureCRT to send the escape code that Ctrl-W would send? Here's how you could map the F5 key:
  • Open Session Options / Terminal / Emulation / Mapped Keys
  • Press the as a workaround button
  • When prompted to press the key you want to map, press the F5 key
  • Function should be Send String
  • Type \027 in the Send String entry box
__________________
Mike
VanDyke Software
Technical Support
[http://www.vandyke.com/support]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:37 AM.