Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-09-2012, 11:11 AM
eborchert eborchert is offline
Registered User
 
Join Date: Oct 2009
Posts: 6
after upgrading secure-crt get prompted to allow/accept networking connections

After upgrading to 7.0.1 I now get error message everytime I open secure-crt asking me to allow incoming network connections from Secure-Crt. I click allow and it works but it prompts everytime.

I also went into Security & Privacy and verify "Secure-Crt" is allowing network connections. I tried removing it and re-adding and it didn't work.

This problem happened as soon as I upgraded so I think somehow security and privacy is confused and looking at the old secure-crt app ? Not sure why or where it would be installed.

Thoughts ?
Reply With Quote
  #2  
Old 10-09-2012, 11:43 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi eborchert,

Thanks for the question. I am not sure what Security & Privacy is, but it doesn't sound like a product that VanDyke Software makes. Have you contacted the vendor of the product to find out why you are getting the error message?

What product are you using that is prompting you?

What operating system are you using?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 10-10-2012, 09:49 AM
eborchert eborchert is offline
Registered User
 
Join Date: Oct 2009
Posts: 6
after upgrading secure-crt get prompted to allow/accept networking connections Repl

I am running Mountain Lion ( 10.8.2 ). Security and Privacy is just a feature of OS X. In my case, I am talking about the firewall feature of Mountain LION. It sounds like you're more familiar with windows. Think of it Security and Privacy as a firewall.

Each time I open Secure-CRT I get this error message:

"Do you want the application "SecureCRT.app" to accept incoming network connections. Clicking Deny may limit the application's behavior. This setting can be changed in the Firewall pane of Security & Privacy preferences"

You can find the firewall on the mac by searching in spotlight "Security & Privacy". Then select the firewall tab. Inside the firewall tab there are options to add applications. I have secure-crt added but I am still seeing this problem.

No other users have reported this problem ? I am trying to find a more gracefull way to clear this than an uninstall/install of SecureCRT
Reply With Quote
  #4  
Old 10-10-2012, 10:29 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi eborchert,

You are correct. I am not familiar with the Mac Firewall, and this may be something you will need to contact Apple to receive assistance in troubleshooting.

I can say that I am not able to reproduce the issue by simply enabling the firewall, and disabling the option to automatically allow signed applications in 10.8.0 using SecureCRT 7.0.1. Maybe my settings differ from yours.

If you can provide more details about your environment, I am happy to see if I can reproduce the issue.

What are all of the Security and Privacy settings you are using for your environment?

Is the device you are trying to connect to in the same network as your machine?

What version of SecureCRT were you using prior to upgrading to SecureCRT 7.0.1?

Were any other changes made around the time that you upgraded SecureCRT?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #5  
Old 10-10-2012, 03:00 PM
eborchert eborchert is offline
Registered User
 
Join Date: Oct 2009
Posts: 6
after upgrading secure-crt get prompted to allow/accept networking connections Reply

thanks for the quick response

This URL describes I think what is happening

http://silvanolte.com/blog/2011/01/1...k-connections/


from my mac

eborcher-mac:Applications eborcher$ codesign -vvv SecureCRT.app/Contents/MacOS/SecureCRT
SecureCRT.app/Contents/MacOS/SecureCRT: a sealed resource is missing or invalid <======
In architecture: i386
resource added: /Applications/SecureCRT.app/Contents/Resources/English.lproj/SecureCRTHelp/SecureCRTHelpMac.helpindex
resource added: /Applications/SecureCRT.app/Contents/Resources/English.lproj/SecureCRTHelp/SO_Connection_SSH2_SFTP_Tab.htm


You said didn't see a problem in 7.0.1 and ML. Can you run that codesign command to see if it reports a problem with the signature ?

I think I upgraded from version 6.7.4, but can't confirm completely. I originally started with 6.7.4, but don't know if I jumped straight to 7.0 or installed some interim release between 7.0 . Is there an install log stored somewhere that I could look at ?
Reply With Quote
  #6  
Old 10-10-2012, 03:44 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi eborchert,

Thanks for the update. We have not had any reports of this issue from other users.

I am fairly certain that my test environment is not similar to yours, but I ran the command that you found, and I see the same error when using SecureCRT 7.0.1.374, and I don't see the issue.

Are you running SecureCRT as an administrator?

Have you tried to remove your SecureCRT installation by dragging it from the LaunchPad to the Trash and then reinstalling it?

Would you be willing to test a pre-release build of SecureCRT to see if additional changes we have made may fix the problem?

If so, would you send a message to support@vandyke.com with a subject of Attn: Todd - Mac Firewall Issue?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #7  
Old 10-11-2012, 02:01 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi all,

At this point, we have been able to determine that the difference in our environments is a port forward in a defined session. We are investigating the reason that the Mac firewall doesn't honor the white list exception for SecureCRT when connecting the session. We will post to this thread when we have more information.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #8  
Old 11-14-2012, 09:07 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi all,

This issue is resolved in SecureCRT 7.0.2. You can download the current official release from the following location:
http://www.vandyke.com/download/securecrt/download.html
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:08 AM.