Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 10-30-2009, 08:39 AM
kminev kminev is offline
Registered User
 
Join Date: Oct 2009
Posts: 21
Disable Secure CRT warning pop-ups

Hi,

I am using Secure CRT for one of my application and always when I connect to a device that the host key is not saved I get the warning message. New Host Key - Accept Once, Accept & Save or Cancel.

This warning message is a show stopper for me can I disable it?

Thank you very much.
Reply With Quote
  #2  
Old 10-30-2009, 09:58 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,634
Hello kminev,

I am not quite sure why the host key warning message is a "show-stopper" for you. The purpose is to identify the remote to which you are connecting as a security precaution for the user.

If you are launching an SSH2 session in SecureCRT via the command-line you can automatically accept host keys via the "/ACCEPTHOSTKEYS" option.

When connecting through the GUI however, until "Accept & Save" is chosen when connecting to a device, this pop-up will appear everytime. Once accepted, you can manage host keys in the 'SSH Host Keys' category of SecureCRT's Global Options.

Does the above explain why the host key warning message appears?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 10-30-2009, 10:34 AM
kminev kminev is offline
Registered User
 
Join Date: Oct 2009
Posts: 21
I do lunch a script from the cmd:

Here is my command I tried in order to execute my vbs script:

securecrt.exe /SCRIPT c:\myScripts\SwitchPortStatus.vbs /ARG SSH2 /ARG myUsername /ARG myPassword /ARG myPassword2 /ARG xxx.xx.xxx.xx /ARG GigabitEthernet1/7 /ARG 7 /ARG c:\temp\ksResult3624.out /ACCEPTHOSTKEYS

That still showed the warning message.
Reply With Quote
  #4  
Old 10-30-2009, 01:15 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,634
Hi kminev,

I was not able to reproduce your results. I tried the command-line as provided and using the "AcceptHostKeys" as an additional "/ARG" to the script.

Do you have a 'Host key database location' defined in the 'SSH Host Keys' category of SecureCRT's Global Options?

Could you supply a screenshot of the warning message you receive when you run the command you last posted?

If it contains sensitive information, send to support@vandyke.com with "Attn Brenda - Forum Thread #4310" in the subject.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 11-04-2009, 11:11 AM
kminev kminev is offline
Registered User
 
Join Date: Oct 2009
Posts: 21
No I don't have hosted database to store my keys.
Reply With Quote
  #6  
Old 11-04-2009, 03:10 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,634
Hello kminev,

"AcceptHostKeys" is a protocol-specific command-line option. Therefore, it needs to be supplied following the protocol.

So if the connection is executed in your script via "crt.Session.Connect", you would want to include the "AcceptHostKeys" option following the protocol. For example:
Code:
If strProtocol = "SSH2" Then
    crt.Session.Connect("/" & strProtocol & " /ACCEPTHOSTKEYS " & strHost)
Else
.
.
.
End If
If you make the appropriate changes to your script and command-line, are host keys accepted automatically?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by jdev; 11-04-2009 at 03:17 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:09 AM.