Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 10-18-2019, 11:26 AM
P1h3r1e3d13 P1h3r1e3d13 is offline
Registered User
 
Join Date: Dec 2017
Posts: 4
Unhappy Strange indentation on keyboard-interactive prompts

Every day I SSH to this server that uses keyboard-interactive login to prompt for MFA authentication. In SecureCRT, each successive line of the prompt is indented to the end of the previous line:


In typewriter/TTY terms, it seems like a line feed without a carriage return. Is there some setting (client or server) I can change to fix this?

For comparison, PuTTY lines things up as I would expect:
Reply With Quote
  #2  
Old 10-18-2019, 03:54 PM
ashiosee ashiosee is offline
Member
 
Join Date: Oct 2019
Posts: 23
SecureCRT seems to be displaying the data in exactly the format provided by the Keyboard-Interactive logon data sent by the server. The server's keyboard-interactive data only includes LF characters -- not CRLF characters.

It seems Putty is making the assumption that all LF chars should be treated as CRLF in this scenario.

I've asked our DEV/QA team to investigate further, and we'll post here with any updates regarding a fix in SecureCRT.
__________________
--Allen

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 10-20-2019, 09:10 PM
P1h3r1e3d13 P1h3r1e3d13 is offline
Registered User
 
Join Date: Dec 2017
Posts: 4
Thanks! LMK if I can get you some config info or something from the server.
Reply With Quote
  #4  
Old 11-05-2019, 04:55 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 938
Dear P1h3r1e3d13,

Our developers have implemented a change to how SecureCRT's displays in-line Keyboard-Interactive data received from a remote system. We believe this change will resolve the errant display issue in SecureCRT.

If you want to try out a newer version of SecureCRT that has the fix in place, please send email to support@vandyke.com with a subject of: "ATTN: Forum thread #13942, post #4".
  • Please send the email from your VanDyke Software download account email address (or in the body of the message, include a reference to the email account you use for downloading installers from our web site).

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #5  
Old 11-06-2019, 11:50 AM
P1h3r1e3d13 P1h3r1e3d13 is offline
Registered User
 
Join Date: Dec 2017
Posts: 4
Thumbs up

Thanks, I emailed.
Reply With Quote
Reply

Tags
securecrt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:56 AM.