Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 09-03-2018, 09:56 AM
Portugal Portugal is offline
Registered User
 
Join Date: Mar 2012
Posts: 9
[SOLVED] Open new sessions on the same instance

Hello.

I've been using SecureCRT for a while, great product
Now that I'm using eve-ng to emulate some routers, every time I click on a router it opens a new session on a new SecureCRT instance, instead of opening that session in a new tab on the same instance.
That's a problem, because if I've 20 routers on the topology, I'll have 20 instances of SecureCRT opened.

Is there a way to force SecureCRT to open new sessions on an already running instance.

I'm using SecureCRT 7.3.7 (x64 build 1034) on Windows 10 1803

Best regards.

Last edited by Portugal; 09-04-2018 at 05:22 AM. Reason: Mark as solved
  #2  
Old 09-03-2018, 10:40 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 422
Hi Portugal,

If you navigate to Options > Global Options > Terminal, do you have the "Connect sessions in tabs" option enabled?

If not, please enable "Connect sessions in tabs".

Does enabling this option provide you with the desired behavior?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
  #3  
Old 09-03-2018, 01:59 PM
Portugal Portugal is offline
Registered User
 
Join Date: Mar 2012
Posts: 9
Quote:
Originally Posted by berdmann View Post
Hi Portugal,

If you navigate to Options > Global Options > Terminal, do you have the "Connect sessions in tabs" option enabled?

If not, please enable "Connect sessions in tabs".

Does enabling this option provide you with the desired behavior?
Hello berdmann.
Yes, that option is already enabled.
It's strange that this behavior is exclusive of eve-ng. It doesn't happen with GNS 3.
Do you have any other suggestions?

Best regards.
  #4  
Old 09-04-2018, 05:01 AM
Portugal Portugal is offline
Registered User
 
Join Date: Mar 2012
Posts: 9
No other suggestions?
I've made a small video showing the issue --> https://mega.nz/#!qTAjzKgC!Rl6lyXMMK...HQ1B4KWA9xZ_aY
Does SecureCRT version 8 solve this issue? If so, I'll upgrade.

Best regards.
  #5  
Old 09-04-2018, 05:21 AM
Portugal Portugal is offline
Registered User
 
Join Date: Mar 2012
Posts: 9
Solved

Hello.

I've found a solution on comment made on a Youtube video.
In order to force SecureCRT to open a new tab instead of a new session, open the Global.ini file located on \Users\<username>\AppData\Roaming\VanDyke\Config, locate the line:
D: "Single Instance" = 00000000
and change it to:
D: "Single Instance" = 00000001
  #6  
Old 09-04-2018, 09:44 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 422
Hi Portugal,

I am happy to hear that you were able to find a work-around by forcing SecureCRT to use a single instance!

Have a great day!
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
  #7  
Old 09-27-2019, 01:19 PM
Manjinder Manjinder is offline
Registered User
 
Join Date: Sep 2019
Posts: 1
Thumbs up

Solution Worked for me as well.

Thank you for the solution !!.

In order to force SecureCRT to open a new tab instead of a new session, open the Global.ini file located on \Users\<username>\AppData\Roaming\VanDyke\Config, locate the line:
D: "Single Instance" = 00000000
and change it to:
D: "Single Instance" = 00000001
  #8  
Old 11-03-2019, 04:18 AM
MRAQAMKL MRAQAMKL is offline
Registered User
 
Join Date: Nov 2018
Posts: 4
Tab in EVE-NG

Changing - D: "Single Instance" = 00000001
did not work for me.. not sure why EVE opens an instance of Secure CRT for each session. I do hope there is a better solution..
  #9  
Old 11-04-2019, 10:02 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 422
Hi MRAQAMKL,

I am not familiar with EVE. Do you mind elaborating on EVE and how you are launching your SecureCRT sessions?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
  #10  
Old 01-04-2021, 12:15 PM
stefan13 stefan13 is offline
Registered User
 
Join Date: Jan 2021
Posts: 2
Hello,

I'm facing the same problem - was there any solution in the meantime?

SecureCRT does open a new window for each SSH/Telnet session for device in EVE-NG.

When I use SecureCRT for Windows, the new session is opened as a Tab.

For both Windows and MacOS the single instance is activated.

D: "Single Instance" = 00000001

Thanks a lot for your support.

brgds
Stefan
  #11  
Old 01-04-2021, 12:40 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,086
Quote:
Originally Posted by stefan13 View Post
I'm facing the same problem - was there any solution in the meantime?

SecureCRT does open a new window for each SSH/Telnet session for device in EVE-NG.

When I use SecureCRT for Windows, the new session is opened as a Tab.

For both Windows and MacOS the single instance is activated.

D: "Single Instance" = 00000001
Dear stefan13,

Would you be so kind as to provide some clarification?
  1. Does your comment, "SecureCRT does open a new window for each SSH/Telnet session for device in EVE-NG" apply only your macOS machine?
  2. What is the exact version of SecureCRT (from the About SecureCRT... window) running on your macOS machine?
  3. What version of macOS are you running on that machine?

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support

Last edited by jdev; 01-04-2021 at 03:22 PM.
  #12  
Old 01-05-2021, 03:18 PM
stefan13 stefan13 is offline
Registered User
 
Join Date: Jan 2021
Posts: 2
Quote:
Originally Posted by jdev View Post
Dear stefan13,

Would you be so kind as to provide some clarification?
  1. Does your comment, "SecureCRT does open a new window for each SSH/Telnet session for device in EVE-NG" apply only your macOS machine?
  2. What is the exact version of SecureCRT (from the About SecureCRT... window) running on your macOS machine?
  3. What version of macOS are you running on that machine?

--Jake
Hello Jake,

the issue occurs only on my MacBook. The Windows version works fine.
I use the latest SecureCRT beta v9.0 on MacOS BigSur.

Thanks
Stefan
  #13  
Old 01-05-2021, 04:37 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,086
Quote:
Originally Posted by stefan13 View Post
the issue occurs only on my MacBook. The Windows version works fine.
I use the latest SecureCRT beta v9.0 on MacOS BigSur.
Stefan,

Thanks for the clarification!

Some earlier versions of SecureCRT v9.0 on macOS platforms introduced a problem where Single Instance functionality was broken.

The next public release of SecureCRT v9.0 (any build v9.0.0.2389 or newer) should resolve the problem you're experiencing on supported macOS platforms. Big Sur is not yet supported, so your mileage may vary.

If you'd like to try out a pre-release version of SecureCRT v9.0 for macOS that's newer than the one you currently have and might resolve the issue, then:
Please send an email message...
  • To: support@vandyke.com
  • From: the email address which corresponds to your VanDyke Software download account
  • Subject: ATTN Forum Thread #13243 - Single Instance Fix for SecureCRT v9 on macOS
If you send the email from your VanDyke Software download account email address (or at least provide the address in your email body), we can make a newer version available to you that may resolve the problem for you in SecureCRT v9.0 on your macOS system.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:26 AM.