Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 05-10-2021, 12:28 PM
schwaboy schwaboy is offline
Registered User
 
Join Date: May 2021
Posts: 7
SecureCRT wide characters getting cut off / emojis not displaying correctly

I'm experiencing an issue where wide UTF-8 characters can get cut off. I'm seeing odd behavior where I can highlight the cut off character, and it will show the full character, even after clearing the highlight.

From searching the forums, it seems this was an issue quite a while ago, and was marked as resolved in version 6.

Additionally, I notice that emojis will render only as an outline, and not as the fully colorized emoji that is part of the installed font. Using a different terminal app, I am able to see the characters as I expect.

I am running v9.0.1 (x64 build 2451) on Windows 10 Pro.



Attached Images
File Type: jpg wEReucG.jpg (28.1 KB, 345 views)
File Type: png QLMHmQP.png (7.9 KB, 333 views)

Last edited by jdev; 05-10-2021 at 12:43 PM. Reason: Please upload attachments/graphics as documented https://forums.vandyke.com/showthread.php?t=14212
Reply With Quote
  #2  
Old 05-10-2021, 01:24 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
Hi schwaboy,

Thanks for providing the screenshots!

What emulation are you using? (Options -> Session Options -> Terminal -> Emulation)

What font/font size is configured? (Options -> Session Options -> Terminal -> Appearance)

Is the "Use Unicode graphics characters" setting enabled?

Which terminal emulator is providing you with the expected results? Putty?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 05-10-2021, 01:33 PM
schwaboy schwaboy is offline
Registered User
 
Join Date: May 2021
Posts: 7
My apologies, I meant to include this information in my initial post, and forgot. I am using Xterm in True Color mode.

I am using FiraCode Nerd Font Mono with a font size of 10.

I also saw in another thread the suggestion to try disabling ClearType font smoothing. I have tried that and get the same results regardless of the state of that setting.
Reply With Quote
  #4  
Old 05-10-2021, 01:37 PM
schwaboy schwaboy is offline
Registered User
 
Join Date: May 2021
Posts: 7
As a comparison, this is what it looks like in another terminal application on the same machine.

Attached Images
File Type: png 5KW5CRO.png (17.7 KB, 329 views)

Last edited by cboyack; 05-10-2021 at 01:41 PM. Reason: Please see this How-To in order to properly embed images: https://forums.vandyke.com/showthread.php?t=14212
Reply With Quote
  #5  
Old 05-10-2021, 01:41 PM
schwaboy schwaboy is offline
Registered User
 
Join Date: May 2021
Posts: 7
I do have "Use Unicode graphics characters" enabled, but I get the same results if I disable that setting. I am using UTF-8 character encoding.
Reply With Quote
  #6  
Old 05-10-2021, 03:23 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
Hi schwaboy,

I have asked our QA/Dev team to take a look into the behavior. It is likely that they will ask me to collect some additional information from you. I will be sure to follow-up with you when I hear back.

What terminal emulator did you use to produce the "working" screenshot?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by berdmann; 05-10-2021 at 03:25 PM.
Reply With Quote
  #7  
Old 05-10-2021, 04:14 PM
schwaboy schwaboy is offline
Registered User
 
Join Date: May 2021
Posts: 7
The other terminal program is "Fluent Terminal" v0.7.5.0
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:59 AM.