Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 11-20-2014, 03:29 PM
Rhudi's Avatar
Rhudi Rhudi is offline
Registered User
 
Join Date: Jul 2013
Location: Greenville, SC
Posts: 80
"The server refused to start a shell."

Every time I log onto a Cisco ASR 9K router using SecureCRT, I get a pop up that says; "The server refused to start a shell.".

It doesn't interfere withing using the session; I can ignore or "OK" the dialog box.

I'd just like my client to stop asking.
Reply With Quote
  #2  
Old 11-20-2014, 03:41 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,307
Hi Rhudi,

It sounds like you are using your router as a jump host. You can enable Do not request a shell which is located in the Connection / Port Forwarding category of the Session Options dialog.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 02-10-2015, 12:01 PM
devon devon is offline
Registered User
 
Join Date: Feb 2015
Posts: 6
Me too

I have this same issue running SecureCRT v7.3.1 on OS X. If I uncheck the "Do not request a shell" box under Connection > Port Forwarding, no shell is created on the ASR9K and I cannot manage it.
Reply With Quote
  #4  
Old 02-10-2015, 12:16 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,307
Hi devon,

Thanks for the post. The option Do not request a shell is not enabled by default.

I ran a test, and if I enable the option, a shell is not requested regardless of the type of remote server, and if the option is disabled, a shell request is made.

Would you provide more details about the problem you are seeing or trying to solve?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #5  
Old 02-13-2015, 10:53 PM
devon devon is offline
Registered User
 
Join Date: Feb 2015
Posts: 6
Hi Todd,

Sure, we have several Cisco ASR routers running IOS-XR version 4.2.3 and when I connect to any of them using SSH, SecureCRT has a pop-up window that says "The server refused to start a shell."

I can click "OK" and move on, but it is an annoyance.

IOS, IOS-XE, and NX-OS devices do not exhibit the same behavior.

This is on SecureCRT for OSX version 7.3.1 (build 685).
Reply With Quote
  #6  
Old 02-14-2015, 01:17 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,307
Hi devon,

Thanks for the update.

How does the Cisco ASR router problem relate to the ASR9K?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #7  
Old 02-20-2015, 12:58 PM
devon devon is offline
Registered User
 
Join Date: Feb 2015
Posts: 6
They are the same in my situation, I just omitted the "9K" part when I said "ASR".

I only have ASR9Ks to test with; I do not have any ASR1Ks. However, some 10G switches I run do have IOS-XE installed and they act fine.
Reply With Quote
  #8  
Old 02-20-2015, 02:40 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,307
Hi devon,

Initially you mentioned:
Quote:
If I uncheck the "Do not request a shell" box under Connection > Port Forwarding, no shell is created on the ASR9K and I cannot manage it.
You have since mentioned:
Quote:
Sure, we have several Cisco ASR routers running IOS-XR version 4.2.3 and when I connect to any of them using SSH, SecureCRT has a pop-up window that says "The server refused to start a shell."
It seems like these two statements contradict each other.

If the device won't allow a shell, I am not sure what we can do in SecureCRT to make it provide a shell when connecting.

Would you provide more details about the problem, how it relates to SecureCRT and your goal?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #9  
Old 02-22-2015, 12:45 AM
devon devon is offline
Registered User
 
Join Date: Feb 2015
Posts: 6
It is an annoyance when connecting to our ASR9Ks and having to click "okay" on the error "The server refused to start a shell".

Last edited by devon; 02-22-2015 at 12:48 AM.
Reply With Quote
  #10  
Old 02-22-2015, 12:47 AM
devon devon is offline
Registered User
 
Join Date: Feb 2015
Posts: 6
Here are the last few lines from a trace where I get the pop-up error and I can manage the router:

Code:
[LOCAL] : RECV : AUTH_SUCCESS
[LOCAL] : SEND[0]: SSH_MSG_CHANNEL_OPEN('session')
[LOCAL] : SEND[0]: Pty Request (rows: 65, cols: 132)
[LOCAL] : RECV[0]: pty request succeeded
[LOCAL] : SEND[0]: agent forwarding request
[LOCAL] : RECV[0]: agent request failed
[LOCAL] : SEND[0]: shell request
[LOCAL] : RECV[0]: shell request failed
[LOCAL] : RECV[0]: Error: receive "succeeded" response for unknown request
And here are the last few lines where I checked "Do not request a shell" which prevents the pop-up error however I cannot manage the router

Code:
[LOCAL] : RECV : AUTH_SUCCESS 
[LOCAL] : Changing state from STATE_CONNECTION to STATE_CLOSING 
[LOCAL] : RECV: Disconnect packet (reason: 11: Disconnected by application.  ) 
[LOCAL] : Changing state from STATE_CLOSING to STATE_CLOSED 
[LOCAL] : Connected for 62 seconds, 1089 bytes sent, 1655 bytes received
[LOCAL] : Stream has closed [CLOSE_TYPE_NONSPECIFIC] : The server has disconnected with an error.  Server message reads: Disconnected by application.

Last edited by devon; 02-22-2015 at 12:49 AM. Reason: formatting
Reply With Quote
  #11  
Old 02-23-2015, 10:13 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,307
Hi devon,

Thanks for clarifying the issue.

The first failure in the first case I see is the "agent forwarding request". Perhaps this failure is confusing the server such that it is failing the subsequent request for a shell, and then sending a "success" to some request unknown to SecureCRT.

If you disable Enable OpenSSH agent forwarding for the session you are using to connect, do you get better results?

The option is located in the Connection / SSH2 / Advanced category of the Session Options dialog.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #12  
Old 02-23-2015, 01:59 PM
devon devon is offline
Registered User
 
Join Date: Feb 2015
Posts: 6
Yep, that did it!

Thanks!
Reply With Quote
  #13  
Old 02-23-2015, 02:58 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,307
Hi devon,

Thanks for the update. Now that we know what is causing the problem, we would like to find out the source of the problem.

To aid in the investigation, I would like to get a log file from a failing connection that is not appropriate for posting in a public forum.

Would you send an email message to support@vandyke.com with a subject of Attn: Todd - Forum thread #11791 so we can discuss the details?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #14  
Old 05-19-2017, 10:38 AM
Joseph.Sheldon Joseph.Sheldon is offline
Registered User
 
Join Date: May 2017
Posts: 1
Thumbs up Thanks!

Came here for answers and found them!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:48 PM.