Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-06-2010, 12:52 PM
WesR WesR is offline
Registered User
 
Join Date: Mar 2005
Location: USA
Posts: 149
ConnectInTab

I'm trying to write a simple script to prompt the user for an IP address and then telnet to that address and login. In the past I've used predefined sessions and then called a script. In this case I just want to be able to run the script from within SecureCRT and have it connect with a new tab.

The problem I'm having is it is giving me an error stating that the session is not connected when it gets to the the WaitforString command. Apparently the script is waiting on input on the original tab, not the newly created tab and I just can't seem to figure out how to get it to wait in the new tab.

Currently I have something like this:

Quote:
crt.session.ConnectInTab(" /telnet " & HostName)
crt.Screen.WaitforString "Login:"
It creates the new tab and connects, but I think I'm missing something to point to the new tab. Hope this makes sense.

Running ver 6.6.1

Wes
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:09 PM.