Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 11-17-2020, 06:05 AM
forall forall is offline
Registered User
 
Join Date: Nov 2020
Posts: 2
Linux screen problem

Hi,

I have a weird problem when I connect to the some linux machine and I must use a screen. After I run screen, my terminal on SecureCRT show information on half screen...

-> show good


-> running screen on linux terminal, show only half window...


I used a xterm-color terminal... I don't have tha problem when I connected via putty or MobaXterm...
Attached Images
File Type: png screen-good.png (19.7 KB, 54 views)
File Type: png linux-screen-run.png (35.0 KB, 49 views)

Last edited by cboyack; 11-17-2020 at 08:15 AM. Reason: Please refer to https://forums.vandyke.com/showthread.php?t=14212 for info on how to embed images on our forums
Reply With Quote
  #2  
Old 11-17-2020, 09:50 AM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 59
Hi forall,

Here's what I suspect is going on:

When using the screen terminal program in your remote Linux system, screen is most likely configured to send specific escape sequences that inform the connecting client program to change its rows and columns to match screen's default row/column settings. SecureCRT, as a good terminal emulator, honors those requests and changes the rows and columns of the connection to match what screen is telling it.

If you desire to change this behavior on SecureCRT's end, please disable the Enable 80/132 column switching option in the Terminal > Emulation > Modes category within SecureCRT's Session Options for a particular session:



Please note that disabling this option may lead to other adverse behavior, as SecureCRT will ignore all mode switching escape sequences in this particular session connection.

If you desire to make this change to multiple sessions at the same time, SecureCRT has a couple of built-in tools for editing settings for all of your sessions (Default Session) or a specific set of multiple sessions.
Attached Images
File Type: png Disable_Column_Switching.png (39.9 KB, 39 views)
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 11-20-2020, 03:18 AM
forall forall is offline
Registered User
 
Join Date: Nov 2020
Posts: 2
Hi Cameron,


This is it :-) Now everything is working, thanks for you help :-)
Reply With Quote
Reply

Tags
half , linux , screen termina , window


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:25 PM.