Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2012, 10:08 PM
conzole conzole is offline
Registered User
 
Join Date: May 2012
Posts: 2
Open session in CRT by typing in run

Hi,

I changed the registry so that hyperlinks work with "ssh2://hostname". It works perfectly with links in Onenote and when I type in internet explorer.

How can I make it also work by typing it into "run" or in the "search" in the windows start menu.

I want to be able to type manually the url there and a session will open in secureCRT in a new tap. It works when I do it by using telnet or "telnet://hostname", but not SSH2.

Can you help?
Reply With Quote
  #2  
Old 05-12-2012, 07:46 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi conzole,

Thanks for the question. What operating system are you using?

Have you enabled the Default URL handler options in the Terminal / Web Browser category of the Global Options dialolg?

Maybe the changes you have made are causing the problem.

What changes have you made to get this to work in other applications?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 05-13-2012, 06:12 PM
conzole conzole is offline
Registered User
 
Join Date: May 2012
Posts: 2
Hi!

Thanks for the response. Yes I have selected secureCRT as default URL handler. But don't know if it works. I press it, it becomes grey, I press OK. And when I go back in, it is no longer grey and I can press it again?... But don't know if that is the problem.

I have windows 7 Professional 32bit operating system.

The change I made was in the registry, so that it would understand ssh2 hyperlinks and would open it in secureCRT by default. Under HKEY_CLASSES_ROOT.

It also started to work in Internet Explorer, but it does not work with Chrome. Might be because of the browser security settings.

But my problem is mainly I want to press "windows" button. To open "Start". And like normally you can type in the search field a telnet command. For example. "telnet://ipaddress" This would open a telnet session in secureCRT. Just like the hyperlinks I make will open. This also works in Chrome browser.

But this does not work same way when I do "ssh2://ipaddress" in Chrome or in the search field in "Start", but it works in explorer and in hyperlinks. And I got no clue why that does not work same way.

Any idea?


Best regards,
Conzole
Reply With Quote
  #4  
Old 05-14-2012, 01:34 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi conzole,

Thanks for the update. I have run some tests, and am not able to get SecureCRT to launch from the Search bar on the Windows 7 start menu when using an SSH2 URL. I have created a feature request to add the ability to use the Search bar to launch SecureCRT. Should this be possible, and added to a future SecureCRT release, we will post to this forum thread.

If you would like to be notified directly, please complete and submit the form at the following location:
Submit Feature Request
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730

Last edited by rtb; 05-14-2012 at 01:41 PM.
Reply With Quote
Reply

Tags
hyperlink , securecrt , ssh2


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:33 PM.