Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-29-2014, 05:33 AM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
UTF-8 at local host connection

I downloaded and installed the latest build SecureCRT on my macbook pro (os x 10.9) and have issue with display cyrillic symbols in local shell.

I switched character settings to Unicode (UTF-8) in session settings, switched font to Monaco, but no effects.

dir listing shows cyrillic folder and files name correctly through standard Terminall.app and iTerm.app





Reply With Quote
  #2  
Old 08-29-2014, 09:15 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi merl,

Thanks for the post. What is the actual version of SecureCRT that you have installed?

What is the output of the following commands in a local shell and Terminal?
echo $LANG
echo $TERM
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 08-31-2014, 10:48 AM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
Hi rtb,


Reply With Quote
  #4  
Old 09-01-2014, 11:20 AM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
sorry, screenshot from Terminal.app

Reply With Quote
  #5  
Old 09-02-2014, 05:54 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Thanks for the additional screenshots merl.

I think that we can find a solution if we can determine what Terminal is doing.

What is set for Character encoding: in the International section of the Advanced category for the Terminal settings/preferences?

Do you have Set locale environment variables on startup in the same section disabled?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730

Last edited by rtb; 09-03-2014 at 10:50 AM.
Reply With Quote
  #6  
Old 09-03-2014, 02:31 AM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
Reply With Quote
  #7  
Old 09-03-2014, 12:06 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi merl,

The screenshot indicates that Set locale environment variables on startup is enabled. Is this a change that you have made?

If so, would you let me know what the output for "echo $LANG" is in terminal?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #8  
Old 09-03-2014, 10:51 PM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
Hi rtb,
Quote:
Is this a change that you have made?
I did not change anything in the settings except color, it's the default setting in the terminal

echo $LANG in terminal here

Last edited by merl; 09-04-2014 at 07:49 AM.
Reply With Quote
  #9  
Old 09-04-2014, 12:03 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi merl,

Since the LANG environment variable is empty in Terminal, would you post the output of "locale" from both Terminal and SecureCRT with a local shell?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #10  
Old 09-04-2014, 12:13 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi merl,

I would also like to have you run a test.

Please edit the Default Session to use UTF-8 for the Character encoding: and change the font to Menlo. After making this change and pressing the OK button, apply the change to the Default Session only.

You can edit the Default Session by pressing the button Edit Default Settings... in the General / Default Session category of the Global Options dialog.

Please post the results of this test as you have a chance.

If this doesn't work, I still want to see the output from the locale command.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #11  
Old 09-04-2014, 01:29 PM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
possible I have found issue source.

Looks like SecureCRT process LC_CTYPE variable incorrectly. If I disable Set locale environment variables on startup checkbox in standart terminal then cyrillic symbols looks like question marks.



If i add string export LC_CTYPE=UTF-8 to .bash_profile, cyrillic symbols are ok in standard terminal,



but SecureCRT have no sense.



It shows variable value, but cyrillic symbols still shows as question marks.

Reply With Quote
  #12  
Old 09-04-2014, 03:37 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi merl,

We are continuing our investigation into this. I will let you know what we find or if we have more questions.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #13  
Old 11-12-2014, 07:26 AM
merl merl is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
Hi rtb,

Do you have any news about my issue solution?
Reply With Quote
  #14  
Old 11-12-2014, 10:18 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Thanks for checking in, merl.

We don't have a solution. I will post here if we have a new build to test or if we have more questions.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:26 AM.