Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-12-2014, 02:56 AM
indy5 indy5 is offline
Registered User
 
Join Date: Aug 2014
Posts: 3
Slow script

Hello,

I want to write an own script for custom GUI dialog, so I tested your script "Create a Custom Username and Password Input Dialog" described in "scripting_essential.pdf" on page2 81-82. But it takes more than 10 seconds to display that IE dialog box. Can you advise what's the problem?

After some investigation it seems that the main delay is caused by the following commands:
g_objIE.Offline = True
g_objIE.navigate "about:blank"

immediately after " Set g_objIE = CreateObject("InternetExplorer.Application") "

I've written some VB scripts for SecureCRT but never had such problem.

If I run that script directly in windows it's fast and the IE dialog box is displayed immediately.

I'm using Windows 7 x64, IE8 on PC with i7, 8GB RAM

Thanks in advance
Reply With Quote
  #2  
Old 08-12-2014, 06:57 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi indy5,

Thanks for the post. What is the version of SecureCRT that you are using?

If you remove any SecureCRT scripting API calls and run the script outside of SecureCRT do you see a delay?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 08-12-2014, 07:11 AM
indy5 indy5 is offline
Registered User
 
Join Date: Aug 2014
Posts: 3
Hello,

I'm using 6.7.3 (build 292) and when I save this script as simple .vbs file (excluding "crt" commands) it runs without any delay and display the dialog box almost immediately.
Reply With Quote
  #4  
Old 08-12-2014, 11:55 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi indy5,

Thanks for the information. I don't see any slowness when running the script example in multiple versions of SecureCRT.

I don't have a test environment with IE8 installed.

Do you have a machine running IE11?

If so, do you see the same slowness on that machine?

Perhaps you have some security settings in IE8 that are causing the slowness.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #5  
Old 08-27-2014, 03:56 AM
indy5 indy5 is offline
Registered User
 
Join Date: Aug 2014
Posts: 3
Hello,

strange, the script works fine on another computer (with IE11) ... unfortunately I can't upgrade the IE on the affected PC - do you have any suggestion which IE8 settings may influence the script's speed? Basically I need to create a combo box so if you have any idea how to solve this problem in different way ...

Many thanks
Reply With Quote
  #6  
Old 08-27-2014, 11:10 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi indy5,

We are not experts on differences between IE11 and IE8 or HTML coding. This is something you may consider contacting Microsoft to ascertain.

I have created a feature request to add the ability to create forms natively in SecureCRT. If we add this feature, we will post to this thread.

If you would like to be notified directly, please complete and submit the form at the following location:
Submit Feature Request
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply

Tags
internet explorer , script , speed


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:35 PM.