Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 11-26-2019, 06:57 PM
allegro allegro is offline
Registered User
 
Join Date: Oct 2019
Posts: 8
Multi-byte language support in session database

Multi-byte language (folder and session name) is used in my session database. When I click the toolbar button in securecrt to open securefx, it is prompted that session information is not found, and the session name is garbled. It should be no match. How can I solve this problem?

The version I use is v8.5.4 build1942 bundled for mac.
Attachment is a screenshot of an error.
Attached Images
File Type: png 截屏2019-11-27上午8.52.10.png (108.3 KB, 166 views)

Last edited by jdev; 12-02-2019 at 09:59 AM.
Reply With Quote
  #2  
Old 11-27-2019, 09:19 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,164
Hi allegro,

What multi-byte language characters are they? Chinese?

If so, if you run the following command from your local shell, what is the output?
echo $LANG
If it's en_US.UTF-8, what are the results if you run the following command in the local shell:
launchctl setenv LANG zh_CN

And then start SecureCRT again? Are you able to successfully launch SecureFX to the same session that has multi-byte characters in the name?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 11-28-2019, 01:22 AM
allegro allegro is offline
Registered User
 
Join Date: Oct 2019
Posts: 8
Quote:
Originally Posted by bgagnon View Post
Hi allegro,

What multi-byte language characters are they? Chinese?

If so, if you run the following command from your local shell, what is the output?
echo $LANG
If it's en_US.UTF-8, what are the results if you run the following command in the local shell:
launchctl setenv LANG zh_CN

And then start SecureCRT again? Are you able to successfully launch SecureFX to the same session that has multi-byte characters in the name?
Yes, it's Chinese characters.
I type echo $LANG in a terminal and press Enter, the response is : zh_CN.UTF-8
My OS is macOS 10.15.1
Reply With Quote
  #4  
Old 11-28-2019, 09:23 PM
allegro allegro is offline
Registered User
 
Join Date: Oct 2019
Posts: 8
Quote:
Originally Posted by bgagnon View Post
Hi allegro,

What multi-byte language characters are they? Chinese?

If so, if you run the following command from your local shell, what is the output?
echo $LANG
If it's en_US.UTF-8, what are the results if you run the following command in the local shell:
launchctl setenv LANG zh_CN

And then start SecureCRT again? Are you able to successfully launch SecureFX to the same session that has multi-byte characters in the name?
after I ran the command you gave me, the code disappeared, but after restarting the computer, the problem came back
Reply With Quote
  #5  
Old 12-02-2019, 11:31 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,164
Hi allegro,
Quote:
after I ran the command you gave me, the code disappeared, but after restarting the computer, the problem came back
That's to be expected with the current workaround as it is not a permanent change. I've asked the developers to come up with a fix or suggest a way to apply that command so it won't be temporary. I'll post here when I have an update.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 12-19-2019, 11:50 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,164
Hi allegro,

The developers believe they have resolved the issue in a pre-release build. You can either wait for beta 3 of v8.7 or send an email to support@vandyke.com. (Attn Brenda - Forum Thread #13987 in the subject line.)

To make the pre-release build available will require a download account. Please include the email address associated with your download account in the body of the email.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 01-05-2020, 03:12 AM
allegro allegro is offline
Registered User
 
Join Date: Oct 2019
Posts: 8
Angry

Quote:
Originally Posted by bgagnon View Post
Hi allegro,

The developers believe they have resolved the issue in a pre-release build. You can either wait for beta 3 of v8.7 or send an email to support@vandyke.com. (Attn Brenda - Forum Thread #13987 in the subject line.)

To make the pre-release build available will require a download account. Please include the email address associated with your download account in the body of the email.
I tried v8.7.0 (build2098) and the problem persists.
Reply With Quote
  #8  
Old 01-06-2020, 08:17 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,164
Hi allegro,

The fix is not in beta 2 (otherwise I would have directed you to that installer, which is available on the website).

The fix is in a build *after* beta 2 and will appear in beta 3 which is scheduled for release this Thursday, January 9.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #9  
Old 01-10-2020, 08:49 AM
allegro allegro is offline
Registered User
 
Join Date: Oct 2019
Posts: 8
Quote:
Originally Posted by bgagnon View Post
Hi allegro,

The fix is not in beta 2 (otherwise I would have directed you to that installer, which is available on the website).

The fix is in a build *after* beta 2 and will appear in beta 3 which is scheduled for release this Thursday, January 9.
So when is the official 8.7.0 release?
Reply With Quote
  #10  
Old 01-10-2020, 08:56 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,164
Hi allegro,

Official release of v8.7 is presently scheduled for January 30, but subject to change.

The best way to stay informed as to release dates is to subscribe to the product announcements.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:21 PM.