Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 08-13-2014, 12:23 PM
muradkhan muradkhan is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
Connect button disabled. How to re-enable

I periodically end up with sessions that seem to have gotten corrupted. Is there a way to reset a session so that the session connection dialog does not display a disabled button.
Reply With Quote
  #2  
Old 08-13-2014, 12:41 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hello muradkhan,

Are you using both SecureCRT and SecureFX?

What version?

Is it in one or the other of the applications that the Connect button is grayed out?

If so, this is generally indicative of a session that was created in SecureCRT when installed as a standalone application (rather than a part of the SecureCRT+SecureFX bundle).
If the bundle is installed later, that older existing session will still be available, but since it was created in SecureCRT (standalone, no File Transfer capability with SecureFX), the File Transfer protocol will be "None" as seen in the Connection category of Session Options:
Terminal protocol (for use with SecureCRT)
and
File transfer protocol (for use with SecureFX)
When you run SecureCRT and SecureFX as separately installed standalone applications pointing to the same configuration folder, the sessions created in SecureCRT will not be "connectable" from within SecureFX until you edit that session in SecureFX and set the File Transfer protocol. Solution? Uninstall SecureCRT, uninstall SecureFX, and install the SecureCRT+SecureFX bundle instead.

If, for some reason, you don't install using the integrated installer and you cannot use a shared config, then the workaround would be to duplicate all the sessions and have one set that is configured for SecureCRT and the other appropriate for use in SecureFX.
Attached Images
File Type: png FileTransfer=None-vs-Otherwise_SessionOptions.png (62.7 KB, 397 views)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730

Last edited by jdev; 02-10-2021 at 02:53 PM.
Reply With Quote
  #3  
Old 08-13-2014, 08:29 PM
muradkhan muradkhan is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
Thanks Brenda

Running SecureCRT 6.7.5. Sorry, I know it's old.

I launch connect, and from the list of available sessions, some have the connect button disabled.
Reply With Quote
  #4  
Old 08-14-2014, 08:21 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,636
Hello muradkhan,

I understand the issue.

Are you saying SecureFX is not installed on the machine at all?

Was the config possibly migrated from an "integrated installation"?

With a bit of reading between the lines, I believe your answer is found in my prior post. Please reread it thoroughly.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 08-15-2014, 12:24 PM
muradkhan muradkhan is offline
Registered User
 
Join Date: Aug 2014
Posts: 7
You were exactly correct. I have now created a folder structure within the Sessions Dialog box, and keep my SecureCRT sessions in one place and my FX connections in another place

Thanks for your astute guidance
Reply With Quote
  #6  
Old 02-09-2021, 10:57 PM
rich@shroop.net rich@shroop.net is offline
Registered User
 
Join Date: Sep 2018
Posts: 2
I also had this problem, but for a different reason. Had to edit the ini file for the session and change

Code:
S:"Transfer Protocol Name"=None
to

Code:
S:"Transfer Protocol Name"=SFTP
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:40 AM.