Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 01-07-2008, 06:38 PM
Xtos Xtos is offline
Registered User
 
Join Date: Jan 2008
Posts: 7
Port forwarding thru a remote computer

I looked on the forums and didn't see a answer on this. If it as already been addressed I'm sorry.

Here is what i need to do...
I work for a company that does database maintenance. We use a program that connects to a database on port, say.... 12345. Normally all we have to do is use the program to connect to the database's external IP and it works just fine because our office IP address is allowed thru our clients firewall. The problem comes in when we are trying to do this from on the road, from a IP thats not in their firewall.
Is there anyway to use SecureCRT's port forwarding ability to ssh to our office linux box then have it make the connection to our clients database?

Any help would be awesome. Thanks.
Reply With Quote
  #2  
Old 01-08-2008, 09:53 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Xtos,

Using port forwarding would be the best option since the IP of the SSH2 server will be used in the connect to the remote machine.

To setup a port forward, just click the 'Add' in the 'Port Forwarding' sub-category under 'Connection' in the 'Session Options' of SecureCRT 5.x.

If this is not 5.x, please let me know as the general instructions are the same but the locations of some of the settings are different.

Once the 'Local Port Forwarding Properties' dialog is open, in the 'Local' section enter the port that SecureCRT should be set to listen on. This can be any port that is not currently being used by the system

In the 'Remote' section, select the option 'Destination host is different from the SSH server' since the SSH2 server is on a different machine then the database server that you need to connect to through the port forward. In the hostname box, enter the hostname of IP for the remote server and the port that the database server is listening on for this connection.

Once setup, just click 'OK' on the dialogs to connect to the session and start the port forward.

When that session is connected, the program used to connect to the database server will need to be configured to use this newly created port forward. The database program should attempt to connect to the localhost on the port configured in the 'Local' section of the port forwarding dialog.

Does this help?
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
  #3  
Old 01-08-2008, 11:10 AM
Xtos Xtos is offline
Registered User
 
Join Date: Jan 2008
Posts: 7
Thanks Teresa,

Yeah that was what I needed. I was trying to do it with the remote/x11 options. Not the "local" options. Everything is working great.

-Xtos
Reply With Quote
  #4  
Old 01-08-2008, 11:19 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Xtos,

I'm glad to hear that the port forward is working!

Please let me know if you have any other questions on port forwarding.
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
  #5  
Old 08-07-2008, 01:55 PM
Xtos Xtos is offline
Registered User
 
Join Date: Jan 2008
Posts: 7
Is something like this possible with RDP as well? Can I use secureCRT to remotely connect to a computer at my office and then have it port forward to 3389 on our clients computer? If its possible... how?
Thanks for all your help.

-Xtos
Reply With Quote
  #6  
Old 08-07-2008, 03:29 PM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Xtos,

Terminal Services runs over TCP port 3389.

This means that all that is required in SecureCRT is a port forward entry in the session options from port 3389 on the local machine to the same port on the remote machine.

When you connect with this session, you should be able to point the Terminal Services Client to 127.0.0.1 (you'll need to enter it by hand because it won't show-up in the dropdown menu) and connect. You should then see the Terminal Services window appear as normal.

If you're trying to use the newer Windows XP "RDP" terminal services client, you may want to consider continuing to use the older ("traditional") Terminal Services Client, and just connect to 127.0.0.1 .

However, if you need to use the XP Remote Desktop client, you'll need to change the local bind address in your port-forward rule to something other than 127.0.0.1 - for example, 127.0.0.2 . Then, if you enter 127.0.0.2 in as the server address for the Remote Desktop Connection client, it should not complain.

Does this help?
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
  #7  
Old 08-07-2008, 03:48 PM
Xtos Xtos is offline
Registered User
 
Join Date: Jan 2008
Posts: 7
Ok... I'm slightly confused...

Tell me if i understand this right...
I am connecting to my office from my house over securecrt on port 22. I have it port forwarded with local port 3389 to remote port 3389 to my CLIENTS computer's ip.

How do I do this part? "you'll need to change the local bind address in your port-forward rule to something other than 127.0.0.1 - for example, 127.0.0.2"

Where do I put 127.0.0.2 in the port forwarding rules?
Reply With Quote
  #8  
Old 08-08-2008, 08:20 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Xtos,

This would be in the Remote Desktop client.

Another option would be to configure the local listening port to something other than 3389.

For example, 33389 and then RDP to localhost:33389

Would this be another option?
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:09 PM.