Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 05-05-2012, 02:26 PM
maxg maxg is offline
Registered User
 
Join Date: Dec 2009
Posts: 22
Odd 7.0.0 bug: missing underscores.

Hello VanDyke,

I recently upgraded to the 7.0.0 beta (build 281) and everything seems to be working fine, except underscores are showing up as spaces. This appears to be happening across multiple fonts, but I'm using Courier New 14pt by default.

I've tried switching fonts, turning on unicode line-drawing and changing the character encoding to multiple different settings (my default is UTF-8).

Is anyone else having this problem? Does anyone know how to fix this?

Thanks!
Reply With Quote
  #2  
Old 05-07-2012, 09:55 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,207
Hi maxg,

I have replicated the reported behavior. It appears both Courier New and Andale Mono display underscores as spaces. The issue does not seem to occur when using Monaco, so that would be the suggested workaround for now.

I have submitted this behavior for investigation by the Development team. Should progress be made toward a resolution, or further information be requested, I will post in this thread.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Attn Brenda - Forum Thread #10445" in the subject line.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 05-10-2012, 06:41 AM
maxg maxg is offline
Registered User
 
Join Date: Dec 2009
Posts: 22
Thanks, I thought I was going crazy after no one responded.

Also I'd like to add a suggestion. I know the font selection screen uses a built in OS interface, but it would really be handy to filter out non fixed-width fonts. It seems sort of silly to show hundreds of fonts if it will only let you select ~10 of them.
Reply With Quote
  #4  
Old 05-10-2012, 08:29 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,207
Hi maxg,

No, you are not crazy!

I have added this thread to a feature request in our product enhancement database to filter out non fixed-width (proportional) fonts from the font list on SecureCRT for Mac OS X. Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Feature Request - Forum Thread #10445" in the subject line.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 05-10-2012, 03:21 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,207
Hi maxg,

The development team believes they have resolved the missing underscores issue in a later build.

If you are interested in receiving the information to download the new build, please send an e-mail to support@vandyke.com and include "Attn Brenda - Forum Thread #10445" in the subject line.

If contacting us through an e-mail account other than the one used to create your download account, please advise us of the download account e-mail address. If you do not have a download account, we can create one and then you will need to complete registration before downloading the new build.

Or, you can wait for the SecureCRT 7.0 beta 2 release (which will include this bug fix). Currently beta 2 release is scheduled for May 22.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 07-30-2012, 01:52 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,207
Hello all,

The development team returned to the drawing board on this issue because it was reported "not fixed" in another thread. We now believe the "missing underscores" issue is resolved in a newer build.

If you are interested in receiving the information to download the new build, please send an e-mail to support@vandyke.com and include "Attn Brenda - Forum Thread #10445" in the subject line.

If contacting us through an e-mail account other than the one used to create your download account, please advise us of the download account e-mail address. If you do not have a download account, we can create one and then you will need to complete registration before downloading the new build.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 08-05-2012, 07:24 PM
maxg maxg is offline
Registered User
 
Join Date: Dec 2009
Posts: 22
Thanks Brenda, the issue seems to be cleared up for me now.
Reply With Quote
  #8  
Old 08-06-2012, 08:02 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,207
Hi maxg,

Thanks for posting the feedback here.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #9  
Old 10-22-2014, 12:08 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,567
Quote:
Originally Posted by maxg View Post
Thanks, I thought I was going crazy after no one responded.

Also I'd like to add a suggestion. I know the font selection screen uses a built in OS interface, but it would really be handy to filter out non fixed-width fonts. It seems sort of silly to show hundreds of fonts if it will only let you select ~10 of them.
This has been implemented in a pre-beta version of SecureCRT for Mac. If you would like to try it, please send email to me at Maureen.Jett@vandyke.com.

Maureen
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:24 AM.