Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 06-25-2014, 07:17 PM
xlq3142 xlq3142 is offline
Registered User
 
Join Date: Jun 2014
Posts: 5
Ctrl-C delay when receiving long input

Use SecureCRT ssh to host a, then ssh to host b from host a, Ctrl-C while delay 5-6s when receiving long input from host b.
Reply With Quote
  #2  
Old 06-26-2014, 07:29 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi xlq3142,

Thanks for the post. I am sorry to hear about the delay. What is the version of SecureCRT that you are using?

How have you configured the SecureCRT connection to the remote server?

Do you see this delay to all hosts?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 06-27-2014, 01:55 AM
xlq3142 xlq3142 is offline
Registered User
 
Join Date: Jun 2014
Posts: 5
Sorry,I need change the description:
Use SecureCRT ssh to host a, then ssh to host b from host a, Ctrl-C while delay 5-6s when receiving long output from host b. (eg, cat a big log file on host b)

SecureCRT Version:7.2.5(x64 build 550)
Every config is defalut values.
I use quick(ALT+R) to connect to remotehost.
The same issus happened on RHEL4 RHEL6 AIX 6.1 SUSE, so i think this delay to all hosts
Reply With Quote
  #4  
Old 06-27-2014, 10:02 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi xlq3142,

Thanks for the information. It sounds like you are using the Default Session. What emulation are you using?

Are you launching a program (e.g. screen) after connecting to the remote shell, but prior to starting cat?

What shell are you using?

Have you tried any other programs from the same machine where SecureCRT is installed?

If so, what speed do you see in them when performing the same task?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #5  
Old 06-28-2014, 01:36 AM
xlq3142 xlq3142 is offline
Registered User
 
Join Date: Jun 2014
Posts: 5
Emulation is vt100.

bash/ksh without lanching any other program.

Putty and Xshell also will delay, but only 1-2s.
Reply With Quote
  #6  
Old 06-29-2014, 08:21 PM
steven_yin steven_yin is offline
Registered User
 
Join Date: Jun 2014
Posts: 1
We are also facing the same issue

We also faced the same issue, but not happen in all the OS.
Reply With Quote
  #7  
Old 06-30-2014, 10:07 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Thanks for the update xlq3142 and for posting steven_yin.

What operating system is in use on the machine where SecureCRT is installed?

What type of network connection is being used to connect from the machine where SecureCRT is installed to the remote servers (speed, latency, etc.)?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #8  
Old 06-30-2014, 06:01 PM
xlq3142 xlq3142 is offline
Registered User
 
Join Date: Jun 2014
Posts: 5
SecureCRT installed on Windows 7 SP1(x64)
Every hosts are in a same gigabit ethernet, latency <1ms.
Reply With Quote
  #9  
Old 07-01-2014, 04:00 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi xlq3142,

Thanks for the update. I have created a feature request to improve the speed with which SecureCRT responds to issuing a Ctrl+C to the remote. If we are able to make improvements, we will post to this forum thread.

If you would like to be notified directly, please complete and submit the form at the following location:
Submit Feature Request
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #10  
Old 07-01-2014, 06:52 PM
xlq3142 xlq3142 is offline
Registered User
 
Join Date: Jun 2014
Posts: 5
Hi rtb,
Thanks for the support.
I have submitted the feature request. Waiting for your good news.

Last edited by xlq3142; 07-01-2014 at 06:57 PM.
Reply With Quote
  #11  
Old 07-02-2014, 08:51 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi xlq3142,

I received your email message and responded with a suggestion to improve the speed.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:37 PM.