Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 01-02-2012, 06:29 AM
thorsten thorsten is offline
Registered User
 
Join Date: Dec 2011
Posts: 37
General keyboard mappings setup problem

Hi,

I have huge problems using SecureCRT, especially getting the standard keyboard bindings in the remote shell to work. I don't have these problems using other Clients like PuTTY or Tunnelier or running (Open) SSH directly in a terminal (like Take Command).

Basically it seems that SecureCRT (as a GUI application) is "consuming" the majority of shortcuts: for instance, none of the Alt- shortcuts work (even those that are not having any functioniality in SecureCRT like Alt-.).

When I'm using SecureCRT, I am working remotely - so I want the majority of keys to work on the remote host and not locally.

So how can I achieve this goal and - at least - have the shortcuts working (like Alt-.) that are not assigned in SecureCRT itself?

Thorsten
Reply With Quote
  #2  
Old 01-02-2012, 08:07 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,599
Hello Thorsten,

What terminal emulation do you have configured in SecureCRT? (Terminal / Emulation category of Session Options)

One of the main options in SecureCRT's default configuration that differs from Putty is that Putty uses Xterm emulation by default.

If you choose Xterm as the emulation and then disconnect/reconnect, what are the results?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-08-2012, 03:10 PM
thorsten thorsten is offline
Registered User
 
Join Date: Dec 2011
Posts: 37
I switched from Linux to xterm: no change (F3 started working in Midnight Commander, but I wouldn't call this a success.

The main difference to PuTTY is that PuTTY doesn't have a menu in his terminal emulator, so the Alt keys are naturally "passed through".
Reply With Quote
  #4  
Old 01-09-2012, 09:52 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,599
Hi Thorsten,

I am not sure what applications specifically you are working in on the remote side, however you should see the same behavior as Putty if you enable Use ALT as meta key in the Terminal / Emulation / Emacs category of SecureCRT's Session Options.

You would also want to be sure Send escape for meta key is enabled (it is by default).
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 01-31-2012, 10:20 AM
thorsten thorsten is offline
Registered User
 
Join Date: Dec 2011
Posts: 37
That did the trick

"Use ALT as meta key" did the trick. I can't use Alt+C/Q anymore but I can live with that.

Thanks.
Reply With Quote
  #6  
Old 01-31-2012, 10:58 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,599
Hi Thorsten,

Thanks for the update.

What did Alt+C and Alt+Q do?

Are you talking about behavior they provided strictly while in Midnight Commander?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:39 PM.