Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 06-17-2014, 02:08 PM
zeromargin zeromargin is offline
Registered User
 
Join Date: Jun 2014
Posts: 1
Unhappy Mac OS X Yosemite Compatibility?

Process: SecureCRT [69538]
Path: /Applications/SecureCRT.app/Contents/MacOS/SecureCRT
Identifier: com.vandyke.SecureCRT
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: SecureCRT [69538]
User ID: 501

Date/Time: 2014-06-17 12:13:51.560 -0700
OS Version: Mac OS X 10.10 (14A261i)
Report Version: 11
Anonymous UUID: FDF633C4-BD50-B906-3531-75D204246E83


Time Awake Since Boot: 6400 seconds

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.5/Python
Referenced from: /Applications/SecureCRT.app/Contents/MacOS/SecureCRT
Reason: no suitable image found. Did find:
/Library/Frameworks/Python.framework/Versions/2.5/Python: no matching architecture in universal wrapper

Binary Images:
0x7fff6dcb9000 - 0x7fff6dcef67f dyld (352.2) <45B33529-4762-3F1D-8E78-A741D5415731> /usr/lib/dyld

Model: MacPro5,1, BootROM MP51.007F.B03, 12 processors, 6-Core Intel Xeon, 3.06 GHz, 64 GB, SMC 1.39f11
Graphics: ATI Radeon HD 5770, ATI Radeon HD 5770, PCIe, 1024 MB
Graphics: ATI Radeon HD 5770, ATI Radeon HD 5770, PCIe, 1024 MB
Memory Module: DIMM 1, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 2, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 3, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 4, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 5, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 6, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 7, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
Memory Module: DIMM 8, 8 GB, DDR3 ECC, 1333 MHz, 0x80AD, 0x484D54333147523742465234432D48392020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (5.106.98.100.24)
Bluetooth: Version 4.3.0d54 14222, 3 services, 27 devices, 1 incoming serial ports
Network Service: Ethernet 1, Ethernet, en0
PCI Card: ATI Radeon HD 5770, Display Controller, Slot-1
PCI Card: ATI Radeon HD 5770, Display Controller, Slot-2
Serial ATA Device: HL-DT-ST DVD-RW GH80N
Serial ATA Device: APPLE SSD SM512E, 500.28 GB
Serial ATA Device: APPLE SSD SM512E, 500.28 GB
Serial ATA Device: APPLE SSD SM512E, 500.28 GB
Serial ATA Device: APPLE SSD SM512E, 500.28 GB
USB Device: Hub
USB Device: Hub
USB Device: Keyboard Hub
USB Device: Apple Keyboard
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Audioengine D1
FireWire Device: built-in_hub, Up to 800 Mb/sec
Thunderbolt Bus:

I upgraded Mac OS X like a dummy and now can't use this! AHHH!
Reply With Quote
  #2  
Old 06-17-2014, 04:20 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi zeromargin,

Thanks for the post. SecureCRT has not been tested on Yosemite. I am sorry to hear that you are having this issue.

Please send an email to support@vandyke.com with a subject of Attn: Support - SecureCRT on Yosemite so we can obtain more information about this issue.

As a note, SecureCRT does require Python 2.5, and since it would appear that Yosemite may have removed that version of Python, this may be the reason for the issue.

I wonder if you created a symlink for what SecureCRT is trying to use that pointed to an existing version of Python if the problem would be resolved.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 06-17-2014, 06:29 PM
cwallace cwallace is offline
Registered User
 
Join Date: Jun 2012
Posts: 8
Also, running into this issue now that I am on the latest Yosemite release (beta 2), SecureCRT worked fine in Yosemite (beta 1).
Reply With Quote
  #4  
Old 06-17-2014, 06:32 PM
cwallace cwallace is offline
Registered User
 
Join Date: Jun 2012
Posts: 8
Oddly enough SecureFX still works...
Reply With Quote
  #5  
Old 06-17-2014, 07:10 PM
jjbird jjbird is offline
Registered User
 
Join Date: Jun 2014
Posts: 1
Updated to Yosemite update 1, and sure enough SecureCRT failed to start with the missing python 2.5 stuff.

Can confirm that a symbolic link of /System/Library/Frameworks/Python.framework/Versions/2.7/Python into /System/Library/Frameworks/Python.framework/Versions/2.5/ allows SecureCRT to run.
Reply With Quote
  #6  
Old 06-18-2014, 09:01 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
@jjbird:
Quote:
Updated to Yosemite update 1, and sure enough SecureCRT failed to start with the missing python 2.5 stuff.

Can confirm that a symbolic link of /System/Library/Frameworks/Python.framework/Versions/2.7/Python into /System/Library/Frameworks/Python.framework/Versions/2.5/ allows SecureCRT to run.
Thanks for the post jjbird. I am glad to hear that this issue is resolved with the symlink.

Out of curiosity, are you able to run a Python script in SecureCRT using the symlink?

@cwallace:
Quote:
Oddly enough SecureFX still works...
SecureFX doesn't link against Python, so this would be expected behavior unless there is something else that is different enough in Yosemite to cause a problem.
Quote:
Also, running into this issue now that I am on the latest Yosemite release (beta 2), SecureCRT worked fine in Yosemite (beta 1).
Are you able to use a symlink to resolve the issue on beta 2?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730

Last edited by rtb; 06-18-2014 at 11:31 AM.
Reply With Quote
  #7  
Old 06-18-2014, 11:10 AM
cwallace cwallace is offline
Registered User
 
Join Date: Jun 2012
Posts: 8
Thanks for the symlink info! I have added the symlink and SecureCRT now launches.
Reply With Quote
  #8  
Old 06-18-2014, 11:36 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Thanks for the update cwallace.

It is good to know that the symlink resolution works in multiple environments.

We will post to this thread with regards to this issue should we have an update in the future.

If anyone would like to be notified about SecureCRT and the Python changes to Yosemite, please complete and submit the form at the following location:
Submit Bug Report
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #9  
Old 08-01-2014, 05:20 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi all,

We have a new build of SecureCRT that resolves this issue. If you would like to use it, please send an email to support@vandyke.com with a subject of Yosemite Python Fix.

This fix will also be available in SecureCRT 7.3 when it enters beta later this month.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #10  
Old 11-12-2014, 03:21 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi all,

The Yosemite Python fix is included in SecureCRT 7.3 official. If you are having problems with SecureCRT 7.3 on Yosemite, please submit the following form:
https://secure.vandyke.com/cgi-bin/c...hp?cft=support
Please do not send an email as directed previously.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:30 PM.