Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 03-05-2018, 10:40 AM
ds-- ds-- is offline
Registered User
 
Join Date: Feb 2018
Posts: 2
unable to get proper character encoding working

I know I use an older version of the software:
Version 7.2.6 (x64 build 606) - Official Release - August 19, 2014

But thats what I paid for a while back, and the functionality I need seems like something very basic, and I am just missing something.

I am unable to get the ascii tables/lines to draw properly. Also it appears to be related, but the quotes and similar characters are not properly reflected.

I tried all types of terminals in securecrt: XTERM, VT100, Linux.
Also all combinations of character encoding from default, to OEM, to windows, etc. I cant get anything to work properly.

The example of what I see on the screen is:
set |egrep "TERM|LANG"
LANG=en_US.UTF-8
TERM=ansi
rm -i 1
rm: cannot remove โ€˜1โ€™: No such file or directory


set |egrep "TERM|LANG"
LANG=en_US.UTF-8
TERM=xterm
rm -i 1
rm: cannot remove β€˜1’: No such file or directory

does anything have any hints? putty works without issues, but thats such a step back...

thanks
Reply With Quote
  #2  
Old 03-05-2018, 12:06 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 919
Quote:
Originally Posted by ds-- View Post
I am unable to get the ascii tables/lines to draw properly.
If things work like you desire in putty, then in SecureCRT you should set your Terminal > Emulation, Terminal to "Xterm" and your Appearance > Character encoding to "UTF-8".

These settings are now the default in newer versions of SecureCRT.

You can employ the power of editing the Default session to make these changes to all of your existing and future sessions. Here are some links to a tip and a video that provide more details about using the Default session to make mass changes to multiple sessions:
https://www.vandyke.com/support/tips/defaultset.html
https://www.youtube.com/watch?v=5RbuZn9L48g
Note: In order for a "change" to be applied to all other sessions, the Default session's option/field you're targeting must actually be modified/different from its current value. This means that if the targeted field you want to apply to all other sessions is already set to the value you want in the Default session, you must first change it to something different -- apply that "change" -- and then edit the Default session again to set the option to its desired value (and apply that "change").
Quote:
Originally Posted by ds-- View Post
Also it appears to be related, but the quotes and similar characters are not properly reflected.
rm -i 1
rm: cannot remove โ€˜1โ€™: No such file or directory
In this case, I'm wondering if you're typing in the command 'rm -i 1' directly into SecureCRT's terminal window, or if you're copying the command from another source and then pasting it into SecureCRT's terminal window from the clipboard.

If you're copying from another app and pasting into SecureCRT's terminal window, it could be that the source from which you copied the command does not have a regular "dash" character (-), but instead has a UNICODE en dash (–) or em dash (—).

Same thing with “smart quotes”. Some applications (MS Word, HTML web pages) don't have quotes as in ASCII Decimal 34 values; instead they may have UNICODE left-quote and right-quote characters which the remote shell doesn't know how to understand. If you do a lot of copying command examples from other sources (like MS Word, or HTML web pages), you may want to configure SecureCRT to convert these upper ASCII (UNICODE) characters into their lower ASCII equivalents so that the remote shell will recognize them. This is done by setting the "Clipboard Format" in the Global.ini file found in SecureCRT's configuration folder to "VDS_TEXT", as described in the Advanced Copy & Paste in SecureCRT video found on the VanDykeSoftware You Tube Channel (specifically the content beginning around the 3:29 mark in the video).
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #3  
Old 03-05-2018, 12:45 PM
ds-- ds-- is offline
Registered User
 
Join Date: Feb 2018
Posts: 2
thank you! Somehow I missed the winning combination...
The ascii/quotes are all fixed with xterm/utf.

PS re your question if it was just a bad copy/paste - it wasnt, just bad example, I should have picked file that existed. I can see how copy/paste can come to mind looking at it now.

Everything is working properly now and globally applied, thanks again!
Reply With Quote
Reply

Tags
ascii , character encoding , terminal


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:43 AM.