Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 01-29-2016, 10:18 PM
hackerchick hackerchick is offline
Registered User
 
Join Date: Jan 2016
Posts: 1
Unhappy Can't SSH into DigitalOcean

I've got SecureCRT 7.3.4 on Windows and a VPS on DigitalOcean running Ubuntu 14.04

I tried giving DigitalOcean the public key created by SecureCRT but it said it was invalid.

So I went into cygwin and created a public key with ssh-keygen -t rsa
This one DigitalOcean accepted

So then, in SecureCRT, Global Options: SSH. I set Public Key to "use identity or certificate file" and pointed it to the id_rsa.pub I created in cygwin.

I then attempted to ssh into my DigitalOcean instance but I get this error:
"Public-key authentication with the server for user root failed.
Please verify username and public/private key pair"

I'm probably doing something stupid but I can't figure out what else to try - can anyone help me out?

Thanks!
Abby
Reply With Quote
  #2  
Old 01-30-2016, 01:42 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,886
Hi Abby,

Quote:
I tried giving DigitalOcean the public key created by SecureCRT but it said it was invalid.
Although you have a workaround to this issue, if you want to determine what happened, I would need additional information about how you created the keypair in SecureCRT and how you tried "giving it to DigitalOcean".

Is the private key, id_rsa (no extension), available in the same location as the .pub file?

It is the private key file that you will use on the client-side to "sign" your public-key so it's important you either configure SecureCRT to point to it or have it available in the same directory as the public-key file.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 02-13-2016, 01:43 PM
clay584 clay584 is offline
Registered User
 
Join Date: Apr 2013
Posts: 2
Quote:
Originally Posted by hackerchick View Post
So then, in SecureCRT, Global Options: SSH. I set Public Key to "use identity or certificate file" and pointed it to the id_rsa.pub I created in cygwin.
You point SecureCRT to use id_rsa, not id_rsa.pub.
Reply With Quote
Reply

Tags
ssh , ssh issue , ssh public key


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:01 AM.