Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-23-2018, 10:36 PM
tenwx tenwx is offline
Registered User
 
Join Date: Jan 2018
Posts: 8
Exclamation Port forwarding problem

I'm using SecureCRT for mac 8.3.1. I want to dynamic port forwarding to local port, and I also want to allow remote hosts to connect to this local port. So I open "Session Options"--"Port Forwarding"--"Add"--click "Manually select local IP address on which to allow connections"--input "0.0.0.0" into "IP Address"--click "Dynamic forwarding using SOCKS 4 or 5".
Finally I found that it can not be accessed to open web pages by this socks5 proxy on remote client, it said "connection refused" or "empty responding". Does I miss something?
Reply With Quote
  #2  
Old 01-24-2018, 07:39 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,902
Hi tenwx,

There seems to be some info missing in between configuration and report of failure.

What IP address are you using for the local connection?

Mac OS only allows localhost, 127.0.0.1 and the machine's IP address to be used by default.

See the How do I get port forwarding to work with loopback addresses ... FAQ on our website here.

If you are using one of the default references in the session you are trying to forward (or have already configured alternative loopback addresses via ifconfig) we will likely need to get Trace Options output. I will wait to see if the above solves your issue before providing instructions for that.

Do not post Trace Options output here in the public forum.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-24-2018, 09:16 AM
tenwx tenwx is offline
Registered User
 
Join Date: Jan 2018
Posts: 8
Quote:
1. Find the .ini file associated with the session that you want to modify. The .ini files are located in the SecureCRT Config folder under the subfolder called Sessions. The Global Options dialog also displays the location of the SecureCRT Config folder in the Configuration folder field.

2. Open the .ini file in Notepad.

3. Look for the following line:

S:"Port Forward Filter"=allow,127.0.0.0/255.0.0.0,0 deny,0.0.0.0/0.0.0.0,0

4. Modify the line to read as follows:

S:"Port Forward Filter"=allow,127.0.0.0/255.0.0.0,0 allow,xxx.xxx.xxx.xxx,0 deny,0.0.0.0/0.0.0.0,0

Alternately, you could modify the line to read as follows allowing any IP address to connect to the port forward:

S:"Port Forward Filter"=allow,0.0.0.0/0.0.0.0,0
Does port-forward filters can be modified by GUI?
Reply With Quote
  #4  
Old 01-24-2018, 09:34 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,902
Hi tenwx,

No, sorry, presently the port forwarding filters are not exposed in the GUI.

I have added this thread to a feature request in our product enhancement database to add GUI options for port forwarding filters. Should a future release of SecureCRT include this feature, notification will be posted here.

If you prefer direct email notification, send an email to support@vandyke.com and include "Feature Request - Forum Thread #12984" in the subject line or use this form from the support page of our website.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
mac , port forwarding , secure crt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:54 PM.