Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 08-31-2017, 10:51 AM
k3npo k3npo is offline
Registered User
 
Join Date: Aug 2017
Posts: 4
Question Keeps asking or private key passphrase

So I have add keys to agent selected in the global SSH setting but it keeps asking for the private passphrase to decrypt my private key for the same server every time I launch a new window to the same server using the same key... Not sure why it's doing that. Help? I've tried a bunch of different things and still no luck getting it to stop prompting.
Reply With Quote
  #2  
Old 08-31-2017, 11:02 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 595
Hi k3npo,

It sounds like when your key pair was created it was configured to use a passphrase. The passphrase is part of the key and is designed to "lock" the key so it can't be used without entering the passphrase. You will be required to enter the passphrase to "unlock" the key each time you want to use it. This is not something that can be stored and automatically entered for you.

It is possible to create a key pair that does not use a passphrase if that is a route you would like to take.

Does this information help clarify?
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 08-31-2017, 11:09 AM
k3npo k3npo is offline
Registered User
 
Join Date: Aug 2017
Posts: 4
Yes I know that is has a passphrase, and on previous installs of SecureCRT it would ask for that passphrase *ONCE* and the never ask again during the time I was using the session. For some reason on this install (which was a backup via XML export/import, but I did copy my correct keys over from the old machine as well) it asks for it EVERY single time. Using the same exact key on my previous machine and install it never faced this behavior. Also on my terminal windows I have used ssh-copy-id so those too never prompt for the passphrase.

The expected behavior I have is for it to ask for the passphrase once and not again. It seems to only be with one particular server as well which is further perplexing (and annoying as I use that server as a jump host for many other servers downstream of it). Other servers in my environment using the same exact SSH key pair don't have this behavior.
Reply With Quote
  #4  
Old 08-31-2017, 11:13 AM
k3npo k3npo is offline
Registered User
 
Join Date: Aug 2017
Posts: 4
Also this is the behavior I used to have:
https://www.vandyke.com/support/howto/002.html

I'd enter the passphrase once like that doc says per launch of SecureCRT.

That behavior is not happening on my current install.
Reply With Quote
  #5  
Old 08-31-2017, 11:45 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 595
Hi k3npo,

I apologize, I may have provided some inaccurate information.

If you choose Manage Agent Keys from the main Tools drop down menu do you find the key you are attempting to use listed?

If so, you indicated that the same key pair works for other servers but not this one. Reviewing some log information of both successful and unsuccessful connection attempts would be beneficial. Because logs can contain sensitive data we ask that you don't post logs to the forums.

Can you take these steps and send the resulting log file to Support@VanDyke.com with "Attn: Eric Forum Post 12798" in the subject line?

- Launch SecureCRT and open SecureCRT's main "File" menu and select the "Trace Options" menu item.

- Open the "File" menu again and choose "Log Session..."
--> Specify a path to your Desktop folder and a name of the log file, such as SCRT_Log.txt. For example: %APPDATA%\..\..\Desktop\SCRT_Log.txt

- Now attempt your connection again.

- When the connection fails, open SecureCRT's "File" menu and look at the "Log Session" menu item. If it has a check-mark next to it, click on it to turn off logging.

- Go to your Desktop folder and locate the SCRT_Log.txt file. Please send the SCRT_Log.txt file to me as an attachment to your reply. Please don't paste the contents into the body of your message -- please attach it!
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 08-31-2017, 01:03 PM
k3npo k3npo is offline
Registered User
 
Join Date: Aug 2017
Posts: 4
I'm sending over the logs now. Note - the connection doesn't fail, the problem is just that it ALWAYS asks for the passphrase and only for this specific server which is used as a jump host to a TON of my other servers.
Reply With Quote
  #7  
Old 08-31-2017, 01:49 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 595
Hi k3npo,

I've gotten the logs you've sent in. I'll review them and respond via email shortly.

Thanks for getting me the additional information.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #8  
Old 09-21-2018, 01:17 PM
mrlawrencelam mrlawrencelam is offline
Registered User
 
Join Date: Sep 2018
Posts: 1
You can disable the passphase. Do this:

1) Under the terminal manager, right-click on the terminal you want to modify and select PROPERTIES.

2) Go under SSH2, highlight PUBLICKEY and click on the PROPERTIES button next to it.

3) Select CHANGE PASSPHASE.

4) Key in the current passphase and leave the new passphase and confirm new passphase blank.

Save it and hurray. You won't be asked for the passphase again.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:35 AM.