Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Reply
 
Thread Tools Display Modes
  #1  
Old 05-04-2015, 01:53 PM
ynoworkie ynoworkie is offline
Registered User
 
Join Date: May 2015
Posts: 9
SCP to CISCO not working

trying to SCP to a CISCO ASR1002. it appears to authenticate and then tries to set parameters and view directory.

i SENT : USERAUTH_REQUEST [none]
i RECV : USERAUTH_FAILURE, continuations [publickey,keyboard-interactive,password]
i SENT : USERAUTH_REQUEST [password]
i RECV : AUTH_SUCCESS
i SEND[0]: SSH_MSG_CHANNEL_OPEN('session')
i SEND[0]: Pty Request (term: vt100, rows: 1024, cols: 256)
i RECV[0]: pty request succeeded
i SEND[0]: shell request
i RECV[0]: shell request succeeded
i RECV[0]:
i SEND[0]: terminal length 0
i RECV[0]: co-pa-19>terminal length 0
i SEND[0]: pwd
i The reply received from the server was not recognized.//
i RECV[0]: co-pa-19>pwd
i RECV[0]: ^
i RECV[0]: % Invalid input detected at '^' marker.
i Channel Closed.
Reply With Quote
  #2  
Old 05-04-2015, 02:14 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi ynoworkie,

Thanks for the post.

What version of SecureFX are you using?

Does your Cisco device require elevation to use SCP?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #3  
Old 05-04-2015, 02:35 PM
ynoworkie ynoworkie is offline
Registered User
 
Join Date: May 2015
Posts: 9
v 7.2.4

I'm not sure about the elevated question. I think so.
Reply With Quote
  #4  
Old 05-04-2015, 02:56 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi ynoworkie,

Thanks for the information. Changes have been made between SecureFX 7.2 and 7.3 with regards to using SCP to connect to Cisco devices.

Do you see better results in 7.3.3?

As a note, changes have been made to 7.3.3 which cause configuration folders to not be backwards compatible. I would recommend making a backup copy of your configuration folder prior to testing 7.3.3 to see if it works better.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #5  
Old 05-05-2015, 03:05 PM
ynoworkie ynoworkie is offline
Registered User
 
Join Date: May 2015
Posts: 9
this may take me a bit, our workstations are locked down from installing software. pretty crazy.
Reply With Quote
  #6  
Old 05-06-2015, 11:33 AM
ynoworkie ynoworkie is offline
Registered User
 
Join Date: May 2015
Posts: 9
upgrade to 7.3.3 works! Thanks.
Reply With Quote
  #7  
Old 05-06-2015, 11:47 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi ynoworkie,

Thanks for the update. It sounds like the device required elevation, and SecureFX 7.2 didn't handle that. The feature was added to 7.3.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #8  
Old 05-06-2015, 01:13 PM
ynoworkie ynoworkie is offline
Registered User
 
Join Date: May 2015
Posts: 9
it did. it prompted me for that during authentication.
Reply With Quote
  #9  
Old 05-27-2015, 01:09 PM
ynoworkie ynoworkie is offline
Registered User
 
Join Date: May 2015
Posts: 9
still having issues

OK, i lied. i can see the files on the cisco device and can add or delete a folder, but i still can't copy the file from one location to the cisco devcie. I'm getting:
i Transfer(00000008): SEND[0]: exec request: scp -t flash:/c3750e-universalk9-mz.150-2.SE7.bin
i Transfer(00000008): File c3750e-universalk9-mz.150-2.SE7.bin could not be opened by server: Administratively disabled.//
i Transfer(00000008): RECV[0]: exec request succeeded
i Transfer(00000008): SUMMARY: Attempted to transfer 1 files.
i Transfer(00000008): SUMMARY: Transferred 0 files successfully.
i Transfer(00000008): SUMMARY: c3750e-universalk9-mz.150-2.SE7.bin: Unable to open destination file.
Reply With Quote
  #10  
Old 05-27-2015, 02:18 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi ynoworkie,

Please send an email to support@vandyke.com with a subject of Attn: Todd - Forum thread #11963.

Please attach a complete log file reflecting the failure.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #11  
Old 05-27-2015, 03:10 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi ynoworkie,

Before you send in the log file, you may consider the following forum thread:
https://forums.vandyke.com/showthread.php?t=11669
The issue that jgolden73 encountered seems very similar to yours. He pointed to a Cisco document that describes how to successfully configure a Cisco device for use with SCP. Here is the URL that he provided:
http://www.cisco.com/en/US/docs/ios-...cure-copy.html
Does the Cisco documentation help you solve this issue?
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
  #12  
Old 05-27-2015, 03:43 PM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi All,

This issue was resolved by enabling the SCP server on the Cisco device.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:45 PM.