Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 06-20-2016, 04:35 PM
realdreams realdreams is offline
Registered User
 
Join Date: Mar 2013
Posts: 25
default session launch order?

I have several sessions in auto session, some sessions depend on others for firewall rule. How can I make some sessions wait for one session to establish before launching?

Thanks
Reply With Quote
  #2  
Old 06-20-2016, 06:04 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 920
So you already have some sessions configured to use others as a firewall (like in a jump host or gateway scenario where your jumphost/gateway is an SSH2 server and you need to get to hosts behind that machine)?

What version of SecureCRT are you using?

If you have a session already configured to connect via a "firewall" that points to another session, you won't need to connect to the "firewall" session first... SecureCRT will automatically connect to it and set up the port forwarding necessary to get through to the secondary host behind the gateway/jumphost.

What specific errors are you seeing?

If you need further assistance with troubleshooting, please send Trace Options output to support@vandyke.com. Trace Options output is best generated by performing these steps:
  1. File -> Log Session, and specify a name for the log file to be generated. Something like %APPDATA%\..\..\Desktop\SCRT_Log.txt will work if you're on Windows.
  2. File -> Trace Options. This won't do anything super fantastic immediately... other than enabling a check-mark for the menu item next time you open the File menu to let you know that it's on/active.
  3. Attempt your connection to the session configured to connect to the secondary host (has as its firewall configuration the session that connects to your gateway/firewall host)
  4. With Trace Options output enabled, you should see a good deal of debug information in SecureCRT's terminal window. Once the connection attempt fails, turn off logging (File -> Log Session again to toggle logging off) and then send the captured log file to support@vandyke.com for further assistance. Don't post this information to the forums, as it can contain sensitive information that I doubt you'll want to be made publicly available to all who visit here.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #3  
Old 06-20-2016, 07:56 PM
realdreams realdreams is offline
Registered User
 
Join Date: Mar 2013
Posts: 25
Code:
Initializing Firewall[SOCKSv5]: 127.0.0.1:44444 

[LOCAL] : SSH2Core version 8.0.0.1082 
[LOCAL] : Connecting to amazon.com:22 ... 
SecureCRT - Version 8.0.1 (build 1082)
[LOCAL] : Changing state from STATE_NOT_CONNECTED to STATE_CLOSED 
[LOCAL] : Connected for 0 seconds, 0 bytes sent, 0 bytes received
                                                                  
[LOCAL] : Stream has closed [CLOSE_TYPE_NONSPECIFIC] : Connection refused

Connection refused
That sounds like a really nice feature however I am not seeing it in 8.0.1 linux

A session that requires "firewall (socks5 proxy)" through another session. It does not automatically launch the "firewall session"
Reply With Quote
  #4  
Old 06-21-2016, 09:28 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 920
Quote:
Originally Posted by realdreams View Post
That sounds like a really nice feature however I am not seeing it in 8.0.1 linux

A session that requires "firewall (socks5 proxy)" through another session. It does not automatically launch the "firewall session"
You actually don't configure an actual SOCKS5 proxy firewall in SecureCRT, you simply point to the existing SSH2 session (the one that connects to the gateway host) using the Firewall setting, choosing "Select Session..." and then selecting the gateway host's session as your firewall. When configured this way, SecureCRT sets everything up for you behind the scenes, dynamically creating port forwarding channels using an SSH2 transport to the gateway session's host.

This is available in 8.0.1 for sure, from both the Quick Connect (ad hoc connection launcher) as well as in Session Options for your saved session to any secondary host.
For Quick Connect:


For a saved session:
Do you not see these options in your SecureCRT on Linux?

If not, then I would venture to say that perhaps you're not really running 8.0.1...

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #5  
Old 06-21-2016, 01:47 PM
realdreams realdreams is offline
Registered User
 
Join Date: Mar 2013
Posts: 25
Thanks Jake. It worked correctly when I select a session for firewall instead of using a user defined firewall from another session.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:17 AM.