Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2012, 04:02 PM
F4RR4R F4RR4R is offline
Registered User
 
Join Date: Feb 2011
Posts: 6
Help Getting ANSI Working Correctly

I'm trying to get ANSI support working correctly with the following scenario.
I've got an Ubuntu 11.10 server running where I do most of my work. I do a lot of work in VIM.

VIM colorschemes typically make use of 256 colors. They're listed here:
http://vim.wikia.com/wiki/Xterm256_c...or_console_Vim

So, I've built a profile in SecureCRT that connects to my server using XTerm as the terminal type with ANSI enabled. The default VIM colorscheme only uses 16 colors and they display correctly. However, as soon as I attempt to use a colorscheme that branches out past those basic 16 colors, I don't see them anymore.

I see in SecureCRT itself in the ANSI tab that there are only 16 colors I can configure in the GUI.

I tried setting my term-type to xterm-color and xterm-256color with no luck, same problems.

Will SecureCRT not support more than 16 colors? I really hope that's not the case, I really like SecureCRT, but I'd like 256 color support.

If it was possible to create a file that specified the RBG codes to be used for specific colors (rather than doing this through the GUI) that would be much better as well.
Reply With Quote
  #2  
Old 03-25-2012, 01:18 AM
MrC MrC is offline
Registered User
 
Join Date: Mar 2004
Posts: 216
SecureCRT supports 256 colors. See screenshot.

Try the vim colortest located here;

http://www.vim.org/scripts/script.php?script_id=1349

Its a perl program you can run to see the colors output.

You do need ANSI Color enabled.
Attached Images
File Type: jpg colortest.jpg (377.8 KB, 631 views)
Reply With Quote
  #3  
Old 03-25-2012, 04:30 PM
F4RR4R F4RR4R is offline
Registered User
 
Join Date: Feb 2011
Posts: 6
Yeah, the colors display beautifully. Must be something broken in my VIM configuration. Thank you
Reply With Quote
  #4  
Old 03-25-2012, 04:37 PM
F4RR4R F4RR4R is offline
Registered User
 
Join Date: Feb 2011
Posts: 6
Just in case anyone else stumbles upon this ...
My server is Ubuntu 11.10x64 & I'm using VIM 7.3. When I am connected locally using gnome-terminal I have 256 color support in VIM. When I connect remotely, I only have 16 color support. The terminal type is XTerm.

I found the solution to my problem on the following link:
http://vim.wikia.com/wiki/256_colors_in_vim

Adding the following line into my .vimrc added support for 256 colors over a remote XTerm session: set t_Co=256
Reply With Quote
Reply

Tags
256 , ansi , color , xterm


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:18 PM.