Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 04-27-2021, 10:41 AM
shalom shalom is offline
Registered User
 
Join Date: Apr 2021
Posts: 9
Fail Connecting with Public Key

Hi All,



I'm evaluating SecureCRT and I try to connect using an existing public key.

I've added the public key to the Properties section and everything looks okay. However, I always get a "Connection refused" error when I try to connect to the remote server.
If I use the terminal or a different client such as iTerm I'm able to connect with no issues.



Does anyone know what I'm doing wrong?


Thanks!
Reply With Quote
  #2  
Old 04-27-2021, 11:46 AM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 132
Hi shalom,

We have often seen that this issue is caused, not by SecureCRT, but rather, by a firewall, switch, router, etc. between you and the remote system. It may also be a local program that isn't even allowing outbound connections from SecureCRT.

In order to have a better idea as to what exactly SecureCRT is seeing, you might want to enable Trace Options (File > Trace Options) prior to attempting to connect to the remote system via SecureCRT.

What information do you see in the Trace Options log regarding this connection issue?

How does it compare to verbose log output from your successful connections?

This post might also offer some additional insight into the issue you're seeing.

If you do share any of that information here on the forums, please mask any sensitive data.
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 04-28-2021, 11:04 AM
shalom shalom is offline
Registered User
 
Join Date: Apr 2021
Posts: 9
Hi Cameron,



Thanks a lot for your help!


The output from ssh -v shows that prior to connecting, it reads a configuration file.

The file describes a port different than the good old port 22.

After changing that, I was able to connect.



Thanks again
Reply With Quote
  #4  
Old 04-28-2021, 12:01 PM
cboyack cboyack is offline
VanDyke Technical Support
 
Join Date: Apr 2020
Location: Albuquerque, NM
Posts: 132
Hi shalom,

You're very welcome. Good job discovering and resolving that pesky port problem.
__________________
Thanks,
--Cameron

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:50 AM.