Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > File Transfer

Reply
 
Thread Tools Display Modes
  #1  
Old 11-03-2011, 09:19 AM
AndreasLandgraf AndreasLandgraf is offline
Registered User
 
Join Date: Nov 2011
Posts: 1
Need to get rid of "ASCII" transfer mode

Hi VanDykes,

there are posts from 2006 and 2007 dealing with the fact that it is't a bug but a feature, that SecureFX generates \r\r\n under certain circumstances when working in ASCII transfer mode. It is not regarded to be buggy (although even some C source code doesn't compile any more after that transformation) since there is some RFC that had been written in the middle ages.

Today, every LINUX vi is capable to handle DOS formatted files and every editor on Windows except the Windows editor is able to handle UNIX files.

So for me there is no reason at all to ever use ASCII transfer mode.

Unfortunately there are several hundreds of file associations in SecureFX, which may spoil txt, html and many other types. There is no way to set them ALL to BINARY, instead I would have to edit them one by one. On my PC at work, on the PC at my home office and on my netbook.

So for me the perfect solution would be to COMPLETELY get rid of ASCII mode. Even the popup, whether I would want to use ASCII or BINARY for an unknown file type is a mess, since it stops the transfer at file #1234 out of 9876 and makes it impossible to transfer bigger directories unattended.

Is there already a chance to do so or do I have a chance to see such an un-feature in one of the next releases?

Thank you for feedback & relief!
Reply With Quote
  #2  
Old 11-03-2011, 09:48 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,522
Hello AndreasLandgraf,

There are solutions to work around the various behaviors you report:

Quote:
So for me the perfect solution would be to COMPLETELY get rid of ASCII mode. Even the popup, whether I would want to use ASCII or BINARY for an unknown file type is a mess, since it stops the transfer at file #1234 out of 9876 and makes it impossible to transfer bigger directories unattended.
  • Set Default transfer type to Binary in the File Transfer category of SecureFX's Global Options

Quote:
Unfortunately there are several hundreds of file associations in SecureFX, which may spoil txt, html and many other types. There is no way to set them ALL to BINARY, instead I would have to edit them one by one. On my PC at work, on the PC at my home office and on my netbook.
  • With SecureFX closed, edit the FileTypes.ini, removing all but one entry. This will clear the list shown in the File Transfer / File Types category of Global Options

FileTypes.ini is found in the config folder. The location of the configuration folder is found in the General category of SecureFX's Global Options.

Additionally, I have added this thread to a feature request in our development database for a Global Option to specify binary or ASCII transfer for every file type. Should a future release of SecureFX include this feature, notification will be posted here.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Feature Request - Forum Thread #9018" in the subject line.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 07-09-2013, 10:42 AM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,592
An option to force every file in a transfer operation to be transferred as binary or ASCII has been added to a pre-beta version of SecureFX. If you would be interested in trying it, please send email to me at Maureen.Jett@vandyke.com.

Maureen
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 12:23 AM.