Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 04-06-2021, 09:38 AM
eva2000 eva2000 is offline
Registered User
 
Join Date: Apr 2004
Location: Brisbane, Australia
Posts: 11
Question Lost linux Screen scrollback buffer on SecureCRT 8 to 9 upgrade?

Seems after I upgraded from SecureCRT 8.x to 9.x on Windows 10, I lost ability to scrollback in my CentOS Linux Screen sessions ? Currently using SecureCRT 9.0.0 x64 build 2430 released on Feb 18, 2021

My Screen has default set to scrollback buffer of 200000 lines in CentOS 7.9 servers I log into

Code:
cat /root/.screenrc 
defscrollback 200000
Code:
rpm -qa screen
screen-4.1.0-0.26.20120314git3c2946.el7.x86_64
Even starting a Screen session with custom scrollback history size doesn't work
Code:
screen -S test -h 200000
I am using Terminal Emulation = Xterm with ANSI with 256 colour mode and Size of logical rows 90 and logical columns 157 with SecureCRT scrollback buffer at 128000 and on resize synchronize view to size. And Emulation mode has initial mode, Line wrap checked with Mode switching Enable 80/132 column switching unchecked.
__________________
..
Reply With Quote
  #2  
Old 04-06-2021, 09:51 AM
eva2000 eva2000 is offline
Registered User
 
Join Date: Apr 2004
Location: Brisbane, Australia
Posts: 11
Seems changing from Terminal emulation mode Xterm with Ansi 256 color to VT100 with Ansi gave me back my screen session's scrollback buffers!
__________________
..
Reply With Quote
  #3  
Old 04-06-2021, 10:38 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,096
Older versions of SecureCRT (prior to 8.7.x) which don't support "true color" (24-bit color codes) present themselves to the remote shell as a terminal of type: "xterm".

Newer versions of SecureCRT (8.7.x and newer) which do support true color present themselves to the remote shell as a terminal of type: "xterm-256color".

It seems that your remote application may not understand what an xterm-256color terminal is, or otherwise might be confused by it.

If you want to have xterm capabilities (rather than relenting to VT100), and avoid confusing the remote app, you can leave the terminal emulation set to Xterm, and then set the Terminal type field to "xterm" in the Terminal > Emulation > Advanced category of Session Options in SecureCRT so that SecureCRT will advertise itself as "xterm" instead of "xterm-256color".

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote
  #4  
Old 04-06-2021, 02:10 PM
eva2000 eva2000 is offline
Registered User
 
Join Date: Apr 2004
Location: Brisbane, Australia
Posts: 11
Quote:
Originally Posted by jdev View Post
If you want to have xterm capabilities (rather than relenting to VT100), and avoid confusing the remote app, you can leave the terminal emulation set to Xterm, and then set the Terminal type field to "xterm" in the Terminal > Emulation > Advanced category of Session Options in SecureCRT so that SecureCRT will advertise itself as "xterm" instead of "xterm-256color".

--Jake
Hi Jake, thanks that seems to have worked too!

much appreciated
__________________
..
Reply With Quote
Reply

Tags
screen , securecrt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:41 AM.