Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 12-29-2011, 04:04 PM
oluckboy oluckboy is offline
Registered User
 
Join Date: Dec 2011
Posts: 2
mouse scroll events

I just upgraded to 6.7.3 on a windows 7 machine. After upgrade everything works great except that mouse scroll events sent to the remote only scroll upward. Is this a known bug? any work around? I haven't been able to find any documentation around it.
Reply With Quote
  #2  
Old 12-29-2011, 04:28 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,395
Hello oluckboy,

I was unable to find any reports of changed behavior regarding Send scroll wheel events to remote in SecureCRT.

What remote application are you accessing where you can only scrolll up via the scroll wheel?

What was the prior version of SecureCRT you were using where this worked correctly?

Other than upgrading to SecureCRT 6.7.3, did any other variables change (operating system where SecureCRT is installed, physical mouse, mouse driver, etc.)?
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 12-29-2011, 06:11 PM
oluckboy oluckboy is offline
Registered User
 
Join Date: Dec 2011
Posts: 2
No changes to my OS or anything else. All i changed on my laptop today was to upgrade to secureCRT 6.7.3. I was on the last version of 6.6 prior to this upgrade.

Some more details. I'm running windows 7 in bookcamp on a mac book air. I've seen that setup sometimes cause some issues in certain software.

I'm SSHing into our development environment at work which runs CentOS release 5.2, I've tried several of our dev machines to see if anything changed on the one i normally access. I see it for every application I open. vim, command line prompts, etc.

Disabled the event forwarding and mouse scrolled the standard window just fine, so I think it's gotta be something in the way it's being forwarded. Not sure what else could be causing it. :/
Reply With Quote
  #4  
Old 12-30-2011, 08:16 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,395
Hello oluckboy,

As a note, we do have SecureCRT for Mac OS X version now.

I think maybe what we should collect is trace options with the debug level set to 9. Since the trace options can contain sensitive information I would like you to send the trace options via e-mail rather than posting it to this forum thread.

Can you edit your session's .ini file and change the trace level line from 0 to 9?
Change this:
D:"Trace Level"=00000000
to this:
D:"Trace Level"=00000009
After making the change, connect to the session and repeat the steps necessary to duplicate the problem. Once the problem occurs, please right-click inside the terminal window and choose Select All, then right-click again and choose Copy to transfer the information to the Windows clipboard. Once copied, please send the information to support@vandyke.com with a subject line that includes "Attn Brenda - Forum Thread #10216".
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 01-27-2012, 11:31 AM
ajazokas ajazokas is offline
Registered User
 
Join Date: Jan 2012
Posts: 1
I am also have a similar problem where mouse scroll wheel events sent to a remote host running vim (version 7.3) or emacs only scroll upward no matter which direction the mouse wheel is turning.

If I run a graphical version, i.e. gvim, the xwindow that opens has the scroll wheel working correctly. The scroll wheel works correctly when at a command line prompt or if connected to the remote host (from Windows) using PUTTY and then running vim.

I'm currently running on Windows XP, and sshing in to a linux development host. Running SecureCRT Version 6.7.3 (build 292) but was getting the same problems when I initially installed SecureCRT on 08-24-2011.
Reply With Quote
  #6  
Old 01-27-2012, 03:02 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,395
Hello ajazokas,

I have been able to replicate the issue you reported. If I recall correctly, I attempted to replicate it when the prior post came in, but could not.

I have submitted this behavior for investigation by Development. Should progress be made toward a resolution, or further information be requested, I will post in this thread.

If you prefer direct e-mail notification, contact support@vandyke.com and include "Bug Report - Forum Thread #10216" in the subject line.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 02-02-2012, 04:37 PM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,395
Hello ajazokas and oluckboy,

We have a build available that should resolve the issue where you could not scroll down with the scroll wheel when Send scroll wheel events to remote is enabled.

If you are interested in receiving the information to download the new build, please send an e-mail to support@vandyke.com and include "Attn Brenda - Forum Thread #10216" in the subject line.

If contacting us through an e-mail account other than the one used to create your download account, please advise us of the download account e-mail address. If you do not have a download account, we can create one and then you will need to complete registration before downloading the build.

The following details will also be needed:
  • 32-bit or 64-bit
  • SecureCRT non-integrated installer or integrated installer
Again, oluckboy, my apologies that we did not get this issue resolved when you posted.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
mouse , scroll


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:09 PM.