Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-11-2020, 04:51 PM
TeamH TeamH is offline
Registered User
 
Join Date: Jul 2020
Posts: 1
Smile import failed for some modules in Securecrt, while it's working on the IDLE

Hello,

I use Securecrt 8.5.3, and Python 2.7.15.

Some modules are imported just fine on the IDLE, but not working on the securecrt giving the below error (ex: telnetlib):

quote/
importError

Error: DLL load failed: The specified module could not be found.

/unquote

sys.path on Securecrt:
C:\Securecrt Folder\SecureCRT8.5\Clients
C:\Securecrt Folder\SecureCRT8.5\Clients\vpython27.zip
C:\Python27\Lib
C:\Python27\DLLs
C:\Python27\Lib\lib-tk
C:\Securecrt Folder\SecureCRT8.5\Clients
C:\Securecrt Folder\SecureCRT8.5\Clients\PythonLibraries
C:\Securecrt Folder\SecureCRT8.5\Clients\SitePackages

sys.path on IDLE:
C:\Windows\SYSTEM32\python27.zip
C:\Python27\DLLs
C:\Python27\lib
C:\Python27\lib\plat-win
C:\Python27\lib\lib-tk
C:\Python27
C:\Python27\lib\site-packages

- I tried to fix that, with no use.

Thanks in advance for any help.
Reply With Quote
 

Tags
import error , python 2.7 , securecrt 8.5.3


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:49 PM.