Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-03-2019, 05:01 AM
IngoThierack IngoThierack is offline
Registered User
 
Join Date: Mar 2019
Posts: 4
Allowed characters in private key passphrase?

Hi,
I'm on Windows 10 64bit, SecureCRT 8.5.4 (x64 Build 1942)

I generated a new key-pair on a Centos 7.7 box with openssl(OpenSSL 1.0.2k), set the passphrase(no ascii character in there) and transferred the private key to the windows-box.
Try to login with the new key on a linux-server. Got the query for the passphrase. And then get an error for invalid password. Tried then from the linux-box with the same key, put the passphrase in, it works.

Change(replace some special characters) the passphrase on the centos-box transfer the privat-key again. Now it works.

I'm always logged in with SecureCRT. But with old key-pair(other password then the new one) or password. So i think is for sure no problem with the keyboard settings.

That leads me to conclusion, there are some characters not allowed in the passphrase in SecureCRT, which are no problems for openssl.

Any hint here if there is a solution for this?

By the way. It would be great to import an manage the private key somehow in SecureCRT itself, so when i copy the settings, it is included. Not the current file-based solution.

Regards,
Ingo
Reply With Quote
 

Tags
openssl , passphrase , privatekey


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:41 PM.