VanDyke Software Forums

Go Back   VanDyke Software Forums > SecureCRT 5.1/SecureFX 3.1/VShell 2.6 Beta
User Name
Password
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
  #1  
Old 04-11-2005, 02:05 AM
dkratter dkratter is offline
Registered User
 
Join Date: Apr 2005
Location: New York, NY
Posts: 13
SecureCRT Charset Request

I would like to request that you add support for the CP437 character set, which is "the old IBM PC character set with block graphics and line-drawing characters" according to the PuTTY website (also called OEM437 or IBM437). It is used heavily by some people on IRC. See http://www.kostis.net/charsets/cp437.htm or http://czyborra.com/charsets/codepages.html for more information.
  #2  
Old 04-13-2005, 05:44 PM
jcj's Avatar
jcj jcj is offline
VanDyke Quality Assurance
 
Join Date: Nov 2003
Posts: 65
dkratter -

Thanks for the feedback.

In CRT/SecureCRT, if you use the Terminal font and the OEM Character encoding (Session Options / Terminal / Appearance), I think you'll see good results (you may also need to uncheck "Use Unicode line drawing characters"). If you could give this a try, we'd be interested to see if this improves things for you with respect to properly displaying CP437.

Please let us know how it goes.

~JcJ
  #3  
Old 04-14-2005, 12:03 AM
dkratter dkratter is offline
Registered User
 
Join Date: Apr 2005
Location: New York, NY
Posts: 13
While your suggestion does work, I would rather not have to be forced to use Terminal font. If you look at PuTTY, you'll see it allows any one of their large list of character sets for any font. I'm able to use Courier New with CP437, and I can get the line-drawing and block characters.
  #4  
Old 04-14-2005, 11:01 AM
jcj's Avatar
jcj jcj is offline
VanDyke Quality Assurance
 
Join Date: Nov 2003
Posts: 65
dkratter -

Since we've verified that that works, the following should get you what you're after with CRT/SecureCRT:
  • Courier New (Session Options / Terminal / Appearance / Font)
  • OEM Character encoding (Session Options / Terminal / Appearance)
  • check "Use Unicode line drawing characters" (Session Options / Terminal / Appearance)

After making these changes in your Session Options, you'll need to reconnect. Does this work for your scenario ?

Please let us know.

~JcJ
  #5  
Old 04-14-2005, 01:28 PM
dkratter dkratter is offline
Registered User
 
Join Date: Apr 2005
Location: New York, NY
Posts: 13
You are a genius. It works! =) It actually works even if Use Unicode is off. Is there supposed to be some difference?
  #6  
Old 04-14-2005, 02:46 PM
jcj's Avatar
jcj jcj is offline
VanDyke Quality Assurance
 
Join Date: Nov 2003
Posts: 65
Great !

Thanks for letting us know.

Whether or not you need "Use Unicode ..." depends on where the line-drawing characters appear in the font, and whether the output transformer you're using maps the line-drawing characters to the right code points. In this case, it appears that it does (which makes sense).

Let us know if you need additional assistance.


~JcJ
  #7  
Old 04-14-2005, 04:01 PM
dkratter dkratter is offline
Registered User
 
Join Date: Apr 2005
Location: New York, NY
Posts: 13
I just found a problem with the OEM character set. Now when I copy/paste, it seems like there's a hidden newline character after each "normal" character, because it pastes each one on its own line. As soon as I go back to the Default character set, the problem disappears.
  #8  
Old 04-14-2005, 04:50 PM
jcj's Avatar
jcj jcj is offline
VanDyke Quality Assurance
 
Join Date: Nov 2003
Posts: 65
Quote:
Originally Posted by dkratter
I just found a problem with the OEM character set. Now when I copy/paste, it seems like there's a hidden newline character after each "normal" character, because it pastes each one on its own line. As soon as I go back to the Default character set, the problem disappears.
Interesting ... Is this within the same application ? E.g. are you copying text from your IRC client and pasting it right back in ?

If so, I'd be curious to see what happens if you try the copy, but then paste into an editor (e.g. vi) or do a cat -ve on the command line (assuming a unix system) and paste there... Do you see the same behavior ?

Either way, this probably shouldn't be happening, but I'd like to get a better idea of what you're seeing. I'm not able to directly reproduce this, but it definitely sounds like you're possibly seeing something you shouldn't.

Thanks,

~JcJ
  #9  
Old 04-15-2005, 11:07 AM
jcj's Avatar
jcj jcj is offline
VanDyke Quality Assurance
 
Join Date: Nov 2003
Posts: 65
dkratter -

Just wanted to let you know that I've gone ahead and submitted this to our developers as a bug (#DEV.10276) . Any additional information you have is welcome, of course :-)

Thanks~

~JcJ
  #10  
Old 04-19-2005, 02:21 PM
dkratter dkratter is offline
Registered User
 
Join Date: Apr 2005
Location: New York, NY
Posts: 13
Just for the record, this is in SecureCRT 4.1.9.

Here is what it should look like (minus the colors):

Code:
03:11 [I] Connecting to port 6666 of server irc.colosolutions.net [refnum 0]
03:11 [I] Looking up your hostname...
03:11 [I] Checking Ident
03:11 [I] Couldn't look up your hostname
03:11 [I] Got Ident response
But after doing 'cat -ve' at the command line, here is what I see:

Code:
0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@C^@o^@n^@n^@e^@c^@t^@i^@n^@g^@ ^@t^@o^@ ^@p^@o^@r^@t^@ ^@6^@6^@6^@6^@ ^@o^@f^@ ^@s^@e^@r^@v^@e^@r^@ ^@i^@r^@c^@.^@c^@o^@l^@o^@s^@o^@l^@u^@t^@i^@o^@n^@s^@.^@n^@e^@t^@ ^@[^@r^@e^@f^@n^@u^@m^@ ^@0^@]^@
^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@C^@o^@n^@n^@e^@c^@t^@i^@n^@g^@ ^@t^@o^@ ^@p^@o^@r^@t^@ ^@6^@6^@6^@6^@ ^@o^@f^@ ^@s^@e^@r^@v^@e^@r^@ ^@i^@r^@c^@.^@c^@o^@l^@o^@s^@o^@l^@u^@t^@i^@o^@n^@s^@.^@n^@e^@t^@ ^@[^@r^@e^@f^@n^@u^@m^@ ^@0^@]^@$
0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@L^@o^@o^@k^@i^@n^@g^@ ^@u^@p^@ ^@y^@o^@u^@r^@ ^@h^@o^@s^@t^@n^@a^@m^@e^@.^@.^@.^@
^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@C^@h^@e^@c^@k^@i^@n^@g^@ ^@I^@d^@e^@n^@t^@
^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@C^@o^@u^@l^@d^@n^@'^@t^@ ^@l^@o^@o^@k^@ ^@u^@p^@ ^@y^@o^@u^@r^@ ^@h^@o^@s^@t^@n^@a^@m^@e^@
^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@G^@o^@t^@ ^@I^@d^@e^@n^@t^@ ^@r^@e^@s^@p^@o^@n^@s^@e^@^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@L^@o^@o^@k^@i^@n^@g^@ ^@u^@p^@ ^@y^@o^@u^@r^@ ^@h^@o^@s^@t^@n^@a^@m^@e^@.^@.^@.^@$
^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@C^@h^@e^@c^@k^@i^@n^@g^@ ^@I^@d^@e^@n^@t^@$
^@0^@3^@:^@1^@1^@ ^@[^@I^@]^@ ^@C^@o^@u^@l^@d^@n^@'^@t^@ ^@l^@o^@o^@k^@ ^@u^@p^@ ^@y^@o^@u^@r^@ ^@h^@o^@s^@t^@n^@a^@m^@e^@$
Resetting the character encoding to Default eliminates the problem.
  #11  
Old 04-21-2005, 04:30 PM
jcj's Avatar
jcj jcj is offline
VanDyke Quality Assurance
 
Join Date: Nov 2003
Posts: 65
dkratter -

Thanks for the response.

Since this was in the 5.0/3.0 beta forum, I assumed you were using 5.0 If you could, I'd be curious to see if you can reproduce this with 5.0 .

FWIW, it looks like you're seeing a NULL character inserted after each normal character when you do the copy/paste.

Thanks again,

~JcJ
  #12  
Old 05-25-2005, 05:17 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,536
dkratter,

We've determined that this problem has been fixed in version 5.0. Please let me know if upgrading to 5.0 doesn't fix the problem for you.

Maureen
  #13  
Old 05-25-2005, 06:40 PM
dkratter dkratter is offline
Registered User
 
Join Date: Apr 2005
Location: New York, NY
Posts: 13
SecureCRT 5.0b5, VT102 (w/ ANSI), Courier New, OEM Character Encoding, Unicode on

What it should be (characters are upper ASCII so they look odd):
Code:
[07:21PM] [ct] 嬪様様様様様様様様様様様様様様様様様様様様様様幼幼陳塚陳陳陳陳
[07:21PM] [ct]    LOCAL USER INFORMATION:
[07:21PM] [ct] 突様様様様様様様様様様様様様様様様様様様様様様幼幼陳塚陳陳陳陳
What I get when I copy/paste after a 'cat -ve':
Code:
[07:21PM] [ct] 嬪様様様様様様様様様様様様様様様様様様様様様様幼幼陳塚陳陳陳陳
[07:21PM] [ct] M-UM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-MM-DM-MM-DM-DM-DM-DM-MM-DM-DM-DM-DM-DM-DM-DM-D$
[07:21PM] [ct]    LOCAL USER INFORMATION:
[07:21PM] [ct] 突様様様様様様様様様様様様様様様様様様様様様様幼幼陳塚陳陳陳陳[07:21PM] [ct] M-3   LOCAL USER INFORMATION:$
If I paste it into a text editor like nano or notepad, it looks correct.

If I use 'cat -ve' with standard ASCII characters, I don't get any of the -MM- stuff, but I still do get some lines repeating and ending with a $.

So the problem seems to have changed between 4.1.9 and 5.0b5, but it is an improvement.
  #14  
Old 08-07-2006, 07:41 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,536
Sorry for taking so long to follow up on this. I was wondering if version 5.1 works any better. If not, please try setting "Clipboard Data Format" in the Global.ini file to "CF_TEXT". This setting is only available in version 5.1 or later.

Maureen
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:35 PM.


copyright 1995-2017 VanDyke Software, Inc.