Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-27-2020, 07:49 AM
sbpaul sbpaul is offline
Registered User
 
Join Date: Jun 2019
Posts: 3
Version 8.7.0 (build 2109) - OSX Suspend

Hey,

currently i see a problem. I got SecureCRT in Background without any connections open. OSX will not going into Automatic Supend on Catalina after my configurated time.

After Closing SecureCRT the supend works correctly.

It would be good when SecureCRT only Prevent from Suspend when Connections are open.

best,
Dennis
Reply With Quote
  #2  
Old 01-27-2020, 09:06 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,153
Hi Dennis,

Please list the explicit steps you take to enable Automatic Suspend.

I scheduled my Catalina machine to sleep at a specified time, had SecureCRT open without connections, and the laptop did go into sleep at the appointed time.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-29-2020, 08:10 AM
sbpaul sbpaul is offline
Registered User
 
Join Date: Jun 2019
Posts: 3
Hi bgagnon,

On Energy Save at Catalina Settings:

I put Blank Screen after 5 Minutes on a Mac.
Newer Macs goes with that to Suspend Mode.

SecureCRT will prevent to go to sleep. So the display will just Blank without Suspend the Macbook.
I have no connections open, just SecureCRT with disconnected tabs.


On Terminal i see this:

pmset -g log |grep SecureCRT


2020-01-29 12:36:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 118:40:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 12:51:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 118:55:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 13:06:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 119:10:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 13:21:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 119:25:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 13:36:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 119:40:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 13:51:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 119:55:16 id:0x0x10000835d [System: PrevIdle DeclUser DispWake kDisp]
2020-01-29 14:06:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 120:10:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 14:21:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 120:25:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 14:36:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 120:40:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 14:51:09 +0100 Assertions PID 1020(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 120:55:16 id:0x0x10000835d [System: PrevIdle DeclUser kDisp]
2020-01-29 15:03:19 +0100 Assertions PID 1020(SecureCRT) Released PreventUserIdleSystemSleep "Disable App Nap per User Request" 121:07:26 id:0x0x10000835d [System: PrevIdle DeclUser IntPrevDisp kDisp]
2020-01-29 15:06:09 +0100 Assertions PID 627(SecureCRT) Summary PreventUserIdleSystemSleep "Disable App Nap per User Request" 00:02:05 id:0x0x100009144 [System: PrevIdle DeclUser IntPrevDisp kDisp]
pid 627(SecureCRT): [0x0002a3ef00019144] 00:04:32 PreventUserIdleSystemSleep named: "Disable App Nap per User Request"
Reply With Quote
  #4  
Old 01-29-2020, 09:29 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,153
Hi sbpaul,

I still cannot replicate that. But based on your results from Terminal, I think you need to disable the Disable App Nap to allow background processing option in the General category of Global Options.

My screen blanks and then sleeps regardless of the SecureCRT option. I could only replicate your results if the System Settings option Prevent computer from sleeping automatically when the display is off was *enabled*.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:48 PM.