Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 02-17-2008, 11:51 PM
sinbad sinbad is offline
Registered User
 
Join Date: Feb 2008
Posts: 11
source is not working properly

hi i am using secure crt 6.0, source comand in linux is not working properly.
I have changed some alias in ./cshrc file and if source this new file. the old alias are not getting removed, the new alias are getting in effect though. is there any other command to clear the old aliases.

thanks
sinbad
Reply With Quote
  #2  
Old 02-18-2008, 10:04 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Sinbad,

This is not a function of SecureCRT itself but more a function of the remote system that SecureCRT is connecting to.

I am not very familiar with the csh shell but I believe that it also has a an 'unalias' command to remove previously defined aliases.

You also may want to check the man pages for the csh shell to see if there are any other options for removing old aliases.

Does this help?
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
  #3  
Old 02-18-2008, 01:04 PM
MrC MrC is offline
Registered User
 
Join Date: Mar 2004
Posts: 216
unalias is the correct command for csh/tcsh.

Sourcing a .cshrc/.tcshrc file does not re-initialize an environment; it simple performs the operations specified in the file.
Reply With Quote
  #4  
Old 02-18-2008, 09:47 PM
sinbad sinbad is offline
Registered User
 
Join Date: Feb 2008
Posts: 11
But it works fine with Putty.
Reply With Quote
  #5  
Old 02-18-2008, 10:02 PM
MrC MrC is offline
Registered User
 
Join Date: Mar 2004
Posts: 216
Your terminal emulator is not changing or deleting aliases in the csh. Your test is mistaken.
Reply With Quote
  #6  
Old 02-19-2008, 08:33 AM
tnygren's Avatar
tnygren tnygren is offline
Registered User
 
Join Date: May 2005
Posts: 1,408
Hi Sinbad,

The aliases are stored on the remote system that SecureCRT is connecting to.

SecureCRT does not know anything about what aliases are defined or are not defined on the remote system.

I'm not certain why there would be any difference with Putty or any other terminal emulator because of where the aliases are stored.

Could you tell me more about the test that was run in Putty?
__________________
Thanks,

Teresa

Teresa Nygren
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:43 AM.