Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 03-06-2014, 09:56 AM
jake1138 jake1138 is offline
Registered User
 
Join Date: Jan 2013
Posts: 17
The network connection was aborted by the local system

Recently, I started having this problem and I'm not sure what is causing it. I'm looking for a little guidance here. After some time (several hours), all my SSH sessions will terminate with the message "The network connection was aborted by the local system". I have not been able to figure out the cause.

I am using SecureCRT 7.0.0. I connect to several (12+) different hosts in our network, some in the local subnet (10.0.5.0/24), some in a remote subnet (10.0.0.0/24). There is no firewall or NAT device between the two networks, just a Linux router in between. I'll get disconnects from both networks at so I know it's not that router causing it.

I have been using this version of SecureCRT for a long time and never had any disconnect problems until the last couple weeks. It could very well be something with my computer but I have no idea what I can do to fix it. I've rebooted and thought that fixed it as I came in the next day and was still connected to everything but then it happened again over my lunch break.

Any help would be much appreciated. Thanks.
  #2  
Old 03-06-2014, 10:17 AM
jake1138 jake1138 is offline
Registered User
 
Join Date: Jan 2013
Posts: 17
I just realized this also happened to an SSH session to a local VirtualBox virtual machine. So that proves this has nothing to do with the physical network. Recently I upgraded VirtualBox so maybe that messed up my network stack. I also installed Windows updates recently so that is suspect as well. I'm going to downgrade VirtualBox and see what happens.
  #3  
Old 03-06-2014, 10:50 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Hi jake1138,

Thanks for the post. SecureCRT is using the local system to establish connections. If the local system is aborting them, the environment is the first thing I would check, especially since SecureCRT has not changed. In this case, the error you see in SecureCRT is just SecureCRT reporting what the local system is telling it when the connection goes down.

It looks like you are on the right track. When I have a system that is working as expected and then starts to have problems, I look at the things that have changed.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
  #4  
Old 03-14-2014, 09:51 AM
jake1138 jake1138 is offline
Registered User
 
Join Date: Jan 2013
Posts: 17
Just an update on this. I have tried rolling back to a restore point well before this started happening and that didn't fix it. I reverted back to the previous version of VirtualBox that I was using and that didn't fix it. I did a network stack reset based on this article but that didn't fix it. I confirmed that this also happens with Putty (Error: Software caused connection abort) so I know it's not just SecureCRT. I'm at a loss as to what to do now. It's driving me nuts. Any ideas?
  #5  
Old 03-14-2014, 11:55 AM
rtb rtb is offline
VanDyke Technical Support
 
Join Date: Aug 2008
Posts: 4,306
Since you seem to have pinpointed the network problem as being something that is outside of the control of TCP client applications themselves, perhaps the next course of action to consider would be to contact VirtualBox for assistance or see if anyone in the VirtualBox community has encountered the same problem and happened upon a solution.

Also, if there is anyone in this forum community that wants to chime in about a solution they might be aware of, please feel free to share.
__________________
--Todd

VanDyke Software
Technical Support
support@vandyke.com
505-332-5730
  #6  
Old 02-09-2021, 09:51 AM
mma238 mma238 is offline
Registered User
 
Join Date: Feb 2021
Posts: 1
The network connection was aborted by the local system

Dear all

Recently I moved to Windows Server 2019 and installed Securecrt and imported settings.

Now the ssh connections interrupt with above error.

What can I do?
  #7  
Old 02-09-2021, 10:30 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,091
Quote:
Originally Posted by mma238 View Post
...the ssh connections interrupt with above error (The network connection was aborted by the local system).

What can I do?
SecureCRT is reporting to you the error as it was received by SecureCRT from the underlying operating system on which you have SecureCRT installed and running (your new Windows 2019 server OS).

You will need to work with your IT staff and network admin team to investigate and resolve issues with the network (VPN, Firewalls, network security appliances/applications, switches, routers, etc.) that are causing the connection to be aborted.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:28 PM.