Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > SecureCRT on the Mac

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 01-12-2016, 10:57 AM
Alan_Mackey Alan_Mackey is offline
Registered User
 
Join Date: Nov 2015
Posts: 7
Annoying disconnections.

I must be accidentally pressing some sort of keyboard shortcut, because sometimes when I try yo type the pipe symbol the active SSH tab disconnects.

Does anyone know if I can somehow disable this behavior? What's the disconnect-current-tab keyboard sequence?

Thanks in advance.
Reply With Quote
  #2  
Old 01-12-2016, 11:44 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,937
Hi Alan_Mackey,

What version of SecureCRT are you using?

Cmd+F4 is the built-in shortcut for disconnecting a tab, but that is so far removed from where the pipe symbol is, I would not expect you to be accidentally choosing that. Especially considering that you may have to also hold down the Fn key on a Mac keyboard.

Do you have any custom keymaps configured?

Is there some text/command you have typed prior to attempting to type the pipe symbol that would send a disconnect to the remote server? (My suspicion is that you are hitting the ENTER key.)
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 01-13-2016, 02:26 AM
Alan_Mackey Alan_Mackey is offline
Registered User
 
Join Date: Nov 2015
Posts: 7
Quote:
Originally Posted by bgagnon View Post
Hi Alan_Mackey,

What version of SecureCRT are you using?
I'm using: Version 7.3.6 (build 963) - Official Release - December 1, 2015


Quote:
Cmd+F4 is the built-in shortcut for disconnecting a tab, but that is so far removed from where the pipe symbol is, I would not expect you to be accidentally choosing that. Especially considering that you may have to also hold down the Fn key on a Mac keyboard.
No, I must be pressing something like Alt or Cmd plus the backslash or the @ key or something similar.

Quote:
Do you have any custom keymaps configured?
I'm afraid not.

Quote:
Is there some text/command you have typed prior to attempting to type the pipe symbol that would send a disconnect to the remote server? (My suspicion is that you are hitting the ENTER key.)
Hmmm... I'll try to reproduce the weird behavior and report back.

Thanks!!!
Reply With Quote
  #4  
Old 01-29-2016, 09:29 AM
Alan_Mackey Alan_Mackey is offline
Registered User
 
Join Date: Nov 2015
Posts: 7
Found the culprits!!!

Whenever I press ALT+e or ALT+minus, the session gets disconnected. So if I slightly miss when I'm gonna type @, it end ups closing the connection.

Is there any way to disable these shortcuts?
Reply With Quote
  #5  
Old 01-29-2016, 11:03 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 3,937
Hi Alan_Mackey,

Thanks for the update.

I'm told Alt+e invokes a certain state on Mac OS, it means the next character typed will be accented with the acute accent (). So I am not sure you would want to disable that combination. You might want to speak to Apple about that.

If you want to configure Alt+- to be disabled, you would:
  • Go to the Terminal / Emulation / Mapped Keys category
  • Press Map a Key...
  • Press the shortcut you desire to configure (Alt+-)
  • Set the FUNCTION to Disable

If you need to make this change to many (or all) sessions, see these tips on our website:
https://www.vandyke.com/support/tips/defaultset.html
https://www.vandyke.com/support/tips/multisessions.html
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #6  
Old 02-01-2016, 03:52 AM
Alan_Mackey Alan_Mackey is offline
Registered User
 
Join Date: Nov 2015
Posts: 7
Quote:
Originally Posted by bgagnon View Post
Hi Alan_Mackey,

Thanks for the update.

I'm told Alt+e invokes a certain state on Mac OS, it means the next character typed will be accented with the acute accent (). So I am not sure you would want to disable that combination. You might want to speak to Apple about that.

If you want to configure Alt+- to be disabled, you would:
  • Go to the Terminal / Emulation / Mapped Keys category
  • Press Map a Key...
  • Press the shortcut you desire to configure (Alt+-)
  • Set the FUNCTION to Disable

If you need to make this change to many (or all) sessions, see these tips on our website:
https://www.vandyke.com/support/tips/defaultset.html
https://www.vandyke.com/support/tips/multisessions.html
That worked marvellously. Thank you!!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:51 PM.