Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Secure Shell

Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2020, 12:01 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
Scrollback no longer working in tmux after update to 8.7.1

I always use tmux sessions connecting to my personal servers. Before 8.7.1 upgrade, the scrollback worked the same as in non-tmux sessions - right side scrollbar would gradually get smaller, i could drag it back to see previous content. Since 8.7.1, this no longer works - scrollbar no longer shrinks as content fills the buffer, so no seamless scrolling back.

This was a huge benefit for me, as the default virtual session scrollback handling always drove me nuts - to the point I just never used it.

I just had a look at the changelog, and see that there were some bugs fixed related to 'screen' - wondering if they're the reason I'm experiencing this...? Is there a setting in tmux I need to adjust?
__________________
Paul Theodoropoulos
Reply With Quote
  #2  
Old 03-24-2020, 01:38 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 382
Hi anastrophe,

I am sorry to hear that you are experiencing some scrollback issues with your tmux sessions post upgrading to 8.7.1!

Does this issue present itself when you connect to any of your non-tmux sessions?

What version were you running prior to 8.7.1? What operating system are you running SecureCRT on?

Would it be at all possible for you to provide a couple of short video clips depicting the behavior with 8.7.1 versus the behavior that you were seeing with the previous version?

If so, please send me an email to support@vandyke.com, with "ATTN: Brittney, Forum Thread# 14123" in the subject line.

For your convenience, the following link can be utilized to direct you to our "Previous Releases" page:
https://www.vandyke.com/download/prevreleases.html
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 03-24-2020, 03:08 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
Thank you for the speedy response, Brittney.

1. Does this issue present itself when you connect to any of your non-tmux sessions?

Yes. The moment I leave the tmux session, the scrollback resumes filling.

2. What version were you running prior to 8.7.1? What operating system are you running SecureCRT on?

Was running 8.7.0, downloaded and installed Mar 1 as best I can recall. OS is Windows 10.

3. Would it be at all possible for you to provide a couple of short video clips depicting the behavior with 8.7.1 versus the behavior that you were seeing with the previous version?

I'll see what I can do. Thanks.
__________________
Paul Theodoropoulos
Reply With Quote
  #4  
Old 03-24-2020, 03:56 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,591
Is the option "Enable 80/132 column switching" checked or unchecked? This is found in the Session Options dialog in the Terminal/Emulation/Modes category.

Maureen
Reply With Quote
  #5  
Old 03-24-2020, 03:59 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
It was checked. I unchecked it and ran through a session, same behavior. Will be emailing video momentarily.
__________________
Paul Theodoropoulos
Reply With Quote
  #6  
Old 03-24-2020, 04:20 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
I'll add that I'm going to hold off on rolling back to 8.7.0 for the moment - this is an inconvenience only at the moment. If further diagnostics are requested I can continue doing them.
__________________
Paul Theodoropoulos
Reply With Quote
  #7  
Old 03-24-2020, 04:59 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,591
Thanks Paul!

Maureen
Reply With Quote
  #8  
Old 03-30-2020, 03:48 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
Just checking in - have my results been reproducible?
__________________
Paul Theodoropoulos
Reply With Quote
  #9  
Old 03-30-2020, 03:57 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,591
Paul,

We are able to reproduce what you're seeing. A change was made to fix a couple of screen command related problems. We're trying to figure out what to do, because we don't want to re-introduce those problems and it appears to be an either/or choice.

Please feel free to roll back to 8.7.0 if this issue is getting in the way.

Maureen
Reply With Quote
  #10  
Old 03-30-2020, 04:18 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
Glad it's not just some bizarro thing with me, I think.

I believe I will roll back when I get a chance - thank you very much, VanDyke has always been extremely responsive to any issue I've had - I really appreciate it.
__________________
Paul Theodoropoulos
Reply With Quote
  #11  
Old 05-14-2020, 05:35 PM
anastrophe anastrophe is offline
Registered User
 
Join Date: Mar 2005
Location: Sonoma County, California, United States of America
Posts: 28
8.7.2?

Got the announcement of 8.7.2 release, but didn't see anything in the changelog re this issue - should I stand pat for now?
__________________
Paul Theodoropoulos
Reply With Quote
  #12  
Old 05-14-2020, 05:51 PM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,591
Yes. This issue hasn't been addressed yet, but someone will be working on it shortly.

Maureen
Reply With Quote
  #13  
Old 05-21-2020, 07:59 AM
SET SET is offline
Registered User
 
Join Date: Jun 2009
Posts: 13
I'm having the same issue but with screen instead of tmux. What's the best way to downgrade to 8.7.0? The installer is telling me I have a newer version installed so there's nothing to do. Would I keep all of my settings if I uninstalled the newer version first?
Reply With Quote
  #14  
Old 05-21-2020, 10:06 AM
Maureen's Avatar
Maureen Maureen is offline
VanDyke Product Director
 
Join Date: Feb 2004
Location: Albuquerque, NM
Posts: 1,591
Yes. I suggest backing up your configuration folder anyway just as a precaution. The location of this folder can be found in the Global Options dialog in the General/Configuration Paths.

Maureen
Reply With Quote
  #15  
Old 06-09-2020, 04:07 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 382
Hello SET,

Our QA/Dev team believe the issue to be resolved in a recent build of SecureCRT. Would you be interested in testing it out? If so, please send an email to support@vandyke.com with "ATTN: Brittney, Forum Thread# 14123" as the subject.

Please provide your download account email address in your message if you are writing in from a different email account.
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:55 AM.