Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 07-24-2020, 11:27 AM
rentyb rentyb is offline
Registered User
 
Join Date: Jul 2020
Posts: 2
SecureCRT 256 columns being reset to 132

Using SecureCRT V8.5.4 on Windows 7 to open terminal on OpenVMS clients. Emulation is set to Xterm, Logical columns to 256, Retain Size and Font. Maximum columns in the Terminal Appearance of Global Options is set to 256.

When I open a terminal , the width is correctly set to 256 :
- I can enter lines up to 256 characters , without the lines being wrapped
- the Bottom status line indicates 79 rows, 256 Cols

But as soon as I enter an OpenVMS command in the terminal to change terminal settings eg. SET TERM/WIDTH=256, the terminal is reset to 132 characters :

- Lines are wrapped at 132 characters
- Bottom status line shows 79 Rows, 132 Cols.

The only way to reset it to 256 chars minimize the screen and maximize it again or to open a new terminal

I suppose the command is sending some escape characters being incorrectly interpreted by SecureCRT.
Is there a way to avoid this, or to reset the terminal with a shortcut ?

Bart
Reply With Quote
  #2  
Old 07-24-2020, 11:50 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,481
Hi Bart,
Quote:
Is there a way to avoid this, or to reset the terminal with a shortcut ?
We would need a raw log to determine the first part.

Have you tried Edit->Reset?

Just based on the info about how maximizing fixes it, would you check the top two Mode switching options in the Terminal / Emulation / Modes category of Session Options?

Is Enable 80/132 column switching and Ignore when maximized or full screen both enabled? If so, if you disable Enable 80/132 column switching, what are the results? (I realize the actual name does not match to the columns you are reporting.)

If that does not resolve the issue, see below for Raw Log instructions.

To create a raw log:
  • Before connecting with the session, select Raw Log Session from SecureCRT's File menu.
  • In the Select Log File dialog, choose a folder and filename in which you would like the log text to be stored and press the Save button. At this point, if you open the File menu, you will notice that the Raw Log Session menu item now has a check-mark next to it; this indicates that raw logging is activated.
  • Now connect to the remote machine and perform the actions that cause the behavior.
  • Select Raw Log Session from the File menu to turn off the raw logging feature (and disconnect the session, if desired).
Since a raw log can contain sensitive information, feel free to send it as an attachment via email to support@vandyke.com. Please reference "Attn Brenda - Forum Thread #14239" in the subject line.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 07-28-2020, 08:55 AM
rentyb rentyb is offline
Registered User
 
Join Date: Jul 2020
Posts: 2
Solved by disabling 80/132 column switching

Edit > Reset didn't change the behavior, but it seems that disabling
Enable 80/132 column switching solved all my problems !

Thanks Brenda !

Bart
Reply With Quote
  #4  
Old 07-28-2020, 09:01 AM
bgagnon bgagnon is offline
VanDyke Technical Support
 
Join Date: Oct 2008
Posts: 4,481
Hi Bart,

Thanks for posting the update! I am glad to hear the issue is resolved.

You can use Default Session to make the change to all sessions.
__________________
Thanks,
--Brenda

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
132 , columns , securecrt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:44 AM.