Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Reply
 
Thread Tools Display Modes
  #1  
Old 07-12-2018, 11:49 AM
nvertedflyer nvertedflyer is offline
Registered User
 
Join Date: Apr 2018
Posts: 10
SecureCRT 8.3.4-1699 Rewriting log destination

I have custom logging set up for:

Session Logs\%Y\%M\%D\%H--%S.log

and it keeps getting overwritten with:

_ScrtLog(%S)_%Y%M%D_%h%m%s.%t.txt

Logging is set to start on connect and append existing file. The global settings and default settings stay correct, but the individual session settings get overwritten.
Reply With Quote
  #2  
Old 07-12-2018, 01:23 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 473
Hi nvertedflyer,

I'm sorry you're having trouble. How are you connecting to your sessions? Are you using saved sessions or ad-hoc connections?

If you are using saved sessions what does the below show as the log parameters?

Code:
Options > Session Options > Log File
If you are using ad-hoc connections what does the following show for log parameters?

Code:
Options > Edit Default Session > Log File
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 07-12-2018, 02:15 PM
nvertedflyer nvertedflyer is offline
Registered User
 
Join Date: Apr 2018
Posts: 10
I'm using saved sessions. The output that you requested is:

Quote:
_ScrtLog(%S)_%Y%M%D_%h%m%s.%t.txt
However, if I look at:

Quote:
Options -> Global Options -> Default Session -> Log File
or

Quote:
Options -> Edit Default Session -> Log File
It shows the correct log settings:

Quote:
%Y\%M\%D\%H--%S.log
Reply With Quote
  #4  
Old 07-12-2018, 02:26 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 473
nvertedflyer,

The settings configured in the Default Session either by navigating to Options > Edit Default Session or Options > Global Options > Default Session only impact new or ad-hoc sessions. These changes do not impact the settings for individual saved sessions that already exist.

You will need to modify the settings for the existing sessions using Session Options. If you would like to make the change to multiple sessions at once you can use standard Shift/CTRL-click behavior to select multiple sessions in the session manager then right click and choose Properties. You should see a warning confirming the number of sessions you are editing. Inside the Session Options choose Log File and make the needed changes.

Does this help get you the behavior you're looking for?
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 07-12-2018, 02:30 PM
nvertedflyer nvertedflyer is offline
Registered User
 
Join Date: Apr 2018
Posts: 10
Yes, I am well aware of the process having used this software for over a decade. That being said, it is not working as it should and settings are being overwritten. I have never, nor would I ever, use the following format for a logfile:

Quote:
_ScrtLog(%S)_%Y%M%D_%h%m%s.%t.txt
This is a new installation on a new machine, so it also is not a config change that has been somehow copied over. I am also the only user of SecureCRT at this organization, so no-one else changed it.

Hence why I am asking for assistance.
Reply With Quote
  #6  
Old 07-12-2018, 02:51 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 473
nvertedflyer,

That's an interesting issue. SecureCRT, by default, does not populate any logging file paths. Did you import session data using a script by chance? The Import Arbitrary Data From File To SecureCRT Sessions script does use this format by default.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 07-12-2018, 03:02 PM
nvertedflyer nvertedflyer is offline
Registered User
 
Join Date: Apr 2018
Posts: 10
I did import via script. That is interesting. I had changed all of the logging after the import, but I didn't pay attention to the original format, good catch.

Any thoughts as to what would make it suddenly revert to old logging settings? I noticed the issue because the log for devices that I had been working on previously suddenly weren't updating, so I know it was working properly beforehand.
Reply With Quote
  #8  
Old 07-12-2018, 03:12 PM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 473
nvertedflyer,

It would be fairly unusual for settings in SecureCRT to revert without some user interaction. Am I understanding the order of events correctly?
  1. Import session data using script
  2. Notice undesired logging path
  3. Update logging path to your desired settings
  4. Confirm that SecureCRT is writing to the correct location
  5. ?
  6. Sessions revert back to the undesired path

When you changed the logging after the import was it done via Session Options?

Roughly how long between you changing the path and it reverting was it?

Was the change you made to the logging path persistent across restarting SecureCRT or does it seem to reset each time to start SecureCRT?
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #9  
Old 07-13-2018, 06:45 AM
nvertedflyer nvertedflyer is offline
Registered User
 
Join Date: Apr 2018
Posts: 10
You are correct with the order of events. The problem was persistent across multiple restarts and even multiple reboots. Interestingly enough, when I came in this morning, the correct paths were there. My PC was rebooted overnight for some software updates (not SecureCRT related). I'm at a loss on this one, but it appears to be working correctly, at least for now.

I'm a long time user of this software and this is the first issue I've had with it, I've been otherwise extremely pleased with it and recommend it to anyone asking for a terminal emulator or SSH client.
Reply With Quote
  #10  
Old 07-13-2018, 08:41 AM
ekoranyi ekoranyi is offline
VanDyke Technical Support
 
Join Date: Jan 2017
Posts: 473
nvertedflyer,

I'm not sure I can explain the behavior your seeing although I am glad to hear that it's currently working as expected. Please don't hesitate to reach out if you run into any further trouble.
__________________
Thanks,
--Eric

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Tags
logging session securecrt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:42 AM.