Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 10-11-2004, 08:49 AM
pgouty pgouty is offline
Registered User
 
Join Date: Oct 2004
Posts: 5
Using a wildcard in a script

Hello,

I am having an issue using a wildcard (*) when running a script. Here is the situation:

My script calls for the source files on a local server as \\sourceserver\sourceshare\*.txt. When I run the script, it finds the 5 files that match this criteria and transfers them successfully to the FTP site. However, in addition to the files, a new directory is created at the site named "*.txt". No matter what I enter as the wildcard, either using * or ?, or part of the file name in front of the wildcard (100123*.txt, for example) a directory is created with that name. If I don't use a wildcard, this phantom directory is not created.

Anyone experience this? I would think it is SecureFX that is creating this, not the FTP site, since SecureFX would determine the files it needed before sending.

Thanks,
Pete
Reply With Quote
  #2  
Old 10-11-2004, 09:03 AM
rlpm's Avatar
rlpm rlpm is offline
VanDyke Developer
 
Join Date: Jun 2004
Location: Albuquerque, NM
Posts: 69
Command Line?

Pete,

What is the entire command line that you are executing?

Thanks,
--rlpm
Reply With Quote
  #3  
Old 10-11-2004, 09:43 AM
pgouty pgouty is offline
Registered User
 
Join Date: Oct 2004
Posts: 5
C:\SecureFX\sfxcl.exe /Q Overwrite never \\OPSQL1\Mainframe\Download\Production\EAI\*.txt /S /EAI_Production
Reply With Quote
  #4  
Old 10-13-2004, 07:42 AM
davidc's Avatar
davidc davidc is offline
VanDyke Software Developer
 
Join Date: Feb 2004
Posts: 44
I have executed a command line similar to yours in sfxcl, but I have not been able to reproduce this behavior with either our FTP or SFTP servers. So, I think there may be something specific to your setup that may be causing the problem.

Can you send us a copy of the log output from sfxcl so that we can see the commands being exchanged in order to narrow in on the problem? You can use the /LOG switch to send the output to a file. Then, you can either send it to support@vandyke.com (with "ATTN: David Coningham" in the body), or just post it here, whichever is easier for you.

Thanks.
Reply With Quote
  #5  
Old 10-13-2004, 08:05 AM
pgouty pgouty is offline
Registered User
 
Join Date: Oct 2004
Posts: 5
Log file...

David,

I have sent an email to the address below with the log file attached. I see in the log file where it appears to be creating the directories...just don't know why.

Thanks,
Pete
Reply With Quote
  #6  
Old 10-13-2004, 09:33 AM
davidc's Avatar
davidc davidc is offline
VanDyke Software Developer
 
Join Date: Feb 2004
Posts: 44
The log shows that you are running version 2.1.5, and it turns out that this bug was fixed in version 2.2. Can you upgrade to the latest version of 2.2 (at the link below) and see if it fixes the problem for you?

http://www.vandyke.com/download/securefx/index.html
Reply With Quote
  #7  
Old 10-13-2004, 09:41 AM
pgouty pgouty is offline
Registered User
 
Join Date: Oct 2004
Posts: 5
Resolved

Thanks David, that worked!

Pete
Reply With Quote
  #8  
Old 11-24-2004, 09:48 AM
drkuhlman03 drkuhlman03 is offline
Registered User
 
Join Date: Nov 2004
Posts: 5
Using pscp to copy files to vshell server with "/" character fails

Hi, we recently upgraded our vshell server to 2.3.1 build 151. We had a number of outside users running a public scp program called pscp (PuTTy).
This used to work prior to the upgrade and I'm not sure if we reset some default root dir settings or something else in the upgrade. But the problem now is that when they run the following command:
pscp -v -pw "passwordgoeshere" c:\sourefile.txt useridgoeshere@sftpserver.com:/targetfilegoeshere.txt

the command fails. If we remove the "/" from the sftpserver.com:targetfilenamegoeshere.txt, it works.

I have some logs of the transfer showing the following:
stp, 00004: Could not map filename filename.txt\ to a valid filename using the defined virtual roots.
Any help would be appreciated.

Thanks!
don
Reply With Quote
  #9  
Old 12-06-2004, 10:05 AM
Llewy Llewy is offline
Registered User
 
Join Date: Dec 2004
Location: UK
Posts: 8
I too have a issue with wildcards...

I too am having wildcard issues.

If the wildcard is at the start of the filename then fine but when I try :

SFXCL /Log C:\log.txt /S "/RESOL - TRA" "BH-TRA/BHR_PPP_????????_TRALetters.txt" "\\villa\bh-resol\PIPELINE\DATA\DATA-IN\20041206"

The file BHR_PPP_20041203_TRALetters.txt exists on the remote machine and :

SFXCL /Log C:\log.txt /S "/RESOL - TRA" "BH-TRA/BHR_PPP_20041203_TRALetters.txt" "\\villa\bh-resol\PIPELINE\DATA\DATA-IN\20041206"

Will download the file.

Do all wildcards have to be at the start of the filename?


SecureFX version 2.2.8 (build 241)
remote Server is vShell for windows version 2.3.0 build 142

Any help would be appreciated.

Many Thanks
Reply With Quote
  #10  
Old 12-07-2004, 11:02 AM
davidc's Avatar
davidc davidc is offline
VanDyke Software Developer
 
Join Date: Feb 2004
Posts: 44
Quote:
Originally Posted by Llewy
Do all wildcards have to be at the start of the filename?
No, the wildcard pattern you specified should work just fine. When I perform a similar transfer with 3.0 (alpha), everything works fine. Does the behavior change if you specify a fully-qualifed path for the source (e.g. /home/user/BH-TRA/...)?

If that does not work, we may ask you to send us a log of the transfer so that we can better determine what's going wrong. But, you may be encountering a bug that we fixed for 3.0, and we may have you try the latest alpha.
Reply With Quote
  #11  
Old 12-09-2004, 05:55 AM
Llewy Llewy is offline
Registered User
 
Join Date: Dec 2004
Location: UK
Posts: 8
Thanks for your prompt reply David, I've worked out the issue and I have to confess a user error upon my part.

The reason why

*_TRALetters.txt worked

and

BHR_PPP_????????_TRALetters.txt didn't

is because the second is programmatically built and the template built

BHR_ppp_????????_TRALetters.txt

-note the lower case ppp!

I'm running this on a windows system and so don't think too hard about case sensitivity.

Doh! Lesson learnt...

Perhaps an "ignore case" switch for the command line interface might be a good enhancement for users like me!

Thanks again for checking it out

Llewy
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 01:12 PM.