Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > General

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 11-07-2017, 05:21 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
SecureCRT 8.3b4: sessions gone after Windows resumes from sleep mode

When I have several SecureCRT sessions open in 8.3.0 beta 4 (x64 build 1509), and Windows 10 enters sleep mode (not just the screen, the entire PC) and I wake it up, SecureCRT is still running but all my SecureCRT sessions are gone (I see an empty window with only the session manager). On the Linux server, a user process such as vi is still running.

I get the same behaviour with Version 8.3.0 (x64 build 1491) on another Windows 10 PC.

I'm not sure, but I don't remember this behaviour from previous versions. I seem to remember that SecureCRT sessions would still be active. Is this perhaps an issue in the beta version?
__________________
René

Last edited by renep; 11-07-2017 at 05:58 AM.
Reply With Quote
  #2  
Old 11-07-2017, 08:57 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
Quote:
When I have several SecureCRT sessions open in 8.3.0 beta 4 (x64 build 1509), and Windows 10 enters sleep mode (not just the screen, the entire PC) and I wake it up, SecureCRT is still running but all my SecureCRT sessions are gone (I see an empty window with only the session manager). On the Linux server, a user process such as vi is still running.

I get the same behaviour with Version 8.3.0 (x64 build 1491) on another Windows 10 PC.

I'm not sure, but I don't remember this behaviour from previous versions. I seem to remember that SecureCRT sessions would still be active. Is this perhaps an issue in the beta version?
Can you describe in detail the steps to reproduce this behavior?

Are you viewing your sessions in tabs or tiles?

Are you saying that as soon as you wake up your computer that the SCRT window is still open but the tabs/tiles of the sessions that were connected are no longer there?

Did you recently make any changes to your SCRT settings?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #3  
Old 11-08-2017, 04:46 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
Quote:
Originally Posted by berdmann View Post
Can you describe in detail the steps to reproduce this behavior?
  • I start SecureCRT 8.3b4, open some sessions to multiple servers
  • Windows 10: Windows button > Power button > Sleep mode
  • Wake up the PC, unlock the screen
  • Stare at empty SecureCRT without active sessions

Quote:
Are you viewing your sessions in tabs or tiles?
In tiles (vertically), or tabs. With the same behaviour.

Quote:
Are you saying that as soon as you wake up your computer that the SCRT window is still open but the tabs/tiles of the sessions that were connected are no longer there?
Exactly.

Quote:
Did you recently make any changes to your SCRT settings?
I enabled "Connect multiple sessions sequentially" as suggested by JJH.

I changed Configuration Path to another network-mapped drive. Could that cause SecureCRT to close/loose sessions?

I can't think of any other changes right now, but I'm not entirely sure.
__________________
René
Reply With Quote
  #4  
Old 11-08-2017, 09:03 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
Hi Renep!

Thank you for the additional information!

It sounds like you may have "Close on Disconnect" enabled.

Please go to Options > Session Options > Terminal and disable "Close on Disconnect".

After making this change you should see your tabs in the SCRT window after your PC resumes from sleep mode, however the sessions will not be connected.

If you would like your sessions to automatically reconnect upon resuming from sleep please go to Options > Global Options > Terminal and enable "Auto Reconnect".

Does this information render the behavior you are looking for?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #5  
Old 11-15-2017, 11:30 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
Hello Brittney,

Quote:
Originally Posted by berdmann View Post
Please go to Options > Session Options > Terminal and disable "Close on Disconnect".
Okay, I did that.

Quote:
After making this change you should see your tabs in the SCRT window after your PC resumes from sleep mode, however the sessions will not be connected.
Yes, that's right. With the consequence that e.g. vim sessions on the server that were running when the PC went into sleep mode are hanging as an orphaned process without a conected terminal, and a long running backup script failed when it attempted ssh authentication.

Quote:
Does this information render the behavior you are looking for?
Well no, not really. I seem to remember that SecureCRT behaved differently in the past, and terminal sessions remained connected when the PC came out of sleep mode. E.g. you could simply continue in a runing vim session.

But I cannot reproduce that behaviour, not with 8.1.4, not with various configurations. Am I mistaken and were connections always dropped by Windows sleep mode
__________________
René
Reply With Quote
  #6  
Old 11-15-2017, 02:43 PM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
Hi Renep!

By default, SecureCRT is designed to disconnect sessions after resuming from sleep.

The following Global.ini only option can be used to prevent sessions from being disconnected when the PC is resumed from sleep mode:

"Disconnect After Resume Timeout"

Please go to C:\Users\username\AppData\Roaming\VanDyke\Config (This is the default Config path, you can view your Config path by going to Options > Global Options > Configuration Paths)
and change the "Disconnect After Resume Timeout" value to "ffffffff"

Does changing this setting in your Global.ini allow your session to remain active upon resuming from sleep?
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #7  
Old 11-16-2017, 09:10 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
Quote:
Originally Posted by berdmann View Post
Does changing this setting in your Global.ini allow your session to remain active upon resuming from sleep?
Yes, it does. Thank you.

Behaviour with this setting is how I remember it from ... sometime in the past. I'm still slightly confused, since I haven't enabled this setting previously, as far as I can remember.
__________________
René
Reply With Quote
  #8  
Old 11-16-2017, 11:30 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
Rene,

I am glad that setting the "Disconnect After Resume Timeout" value to "ffffffff" in your Global.ini did the trick!

In SecureCRT versions 6.5 and earlier the default behavior was to remain connected upon resume from sleep. The Global.ini "Disconnect After Resume Timeout" setting would need to be adjusted manually to achieve this behavior in all versions released after 6.5.
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
  #9  
Old 11-17-2017, 11:00 AM
renep renep is offline
Registered User
 
Join Date: Mar 2006
Location: Amsterdam, the Netherlands
Posts: 56
Quote:
Originally Posted by berdmann View Post
In SecureCRT versions 6.5 and earlier the default behavior was to remain connected upon resume from sleep. The Global.ini "Disconnect After Resume Timeout" setting would need to be adjusted manually to achieve this behavior in all versions released after 6.5.
Aha, that explains it. Thanks for clarifying
__________________
René
Reply With Quote
  #10  
Old 11-17-2017, 11:06 AM
berdmann berdmann is offline
VanDyke Technical Support
 
Join Date: Aug 2017
Posts: 441
I am happy to help!

Have a great day!
__________________
Thanks,
--Brittney

VanDyke Software
Technical Support
support@vandyke.com
(505) 332-5730
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:23 AM.