Welcome to the VanDyke Software Forums

Join the discussion today!


Go Back   VanDyke Software Forums > Scripting

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-19-2021, 08:59 AM
garrettwilliams garrettwilliams is offline
Registered User
 
Join Date: Dec 2020
Posts: 13
trouble importing external modules (SCRT 9.0)

Hey all,

I've been using SecureCRT 9.0 and writing some pretty handy Python3 scripts for a few weeks now. The other day, I shared one of my scripts with a coworker, and they were unable to get it to work.

- They're using SecureCRT 9.0 on Windows 10

- They have Python 3.8.6 installed. This is the version that runs when they enter 'python' at the Windows command line.

- The package in question (PyQt) can be imported from the local Python shell.

- They're using the same scripts I am (Python3 tag used at top)

However, when they go to run the script in SecureCRT, they see a 'ModuleNotFound' error.


Any information on troubleshooting something like this would be greatly appreciated. I'm just quite stumped why, if secureCRT is using the local python interpreter, it doesn't see that module.

Thank you
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:28 AM.