View Single Post
  #2  
Old 03-05-2018, 12:06 PM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 930
Quote:
Originally Posted by ds-- View Post
I am unable to get the ascii tables/lines to draw properly.
If things work like you desire in putty, then in SecureCRT you should set your Terminal > Emulation, Terminal to "Xterm" and your Appearance > Character encoding to "UTF-8".

These settings are now the default in newer versions of SecureCRT.

You can employ the power of editing the Default session to make these changes to all of your existing and future sessions. Here are some links to a tip and a video that provide more details about using the Default session to make mass changes to multiple sessions:
https://www.vandyke.com/support/tips/defaultset.html
https://www.youtube.com/watch?v=5RbuZn9L48g
Note: In order for a "change" to be applied to all other sessions, the Default session's option/field you're targeting must actually be modified/different from its current value. This means that if the targeted field you want to apply to all other sessions is already set to the value you want in the Default session, you must first change it to something different -- apply that "change" -- and then edit the Default session again to set the option to its desired value (and apply that "change").
Quote:
Originally Posted by ds-- View Post
Also it appears to be related, but the quotes and similar characters are not properly reflected.
rm -i 1
rm: cannot remove โ€˜1โ€™: No such file or directory
In this case, I'm wondering if you're typing in the command 'rm -i 1' directly into SecureCRT's terminal window, or if you're copying the command from another source and then pasting it into SecureCRT's terminal window from the clipboard.

If you're copying from another app and pasting into SecureCRT's terminal window, it could be that the source from which you copied the command does not have a regular "dash" character (-), but instead has a UNICODE en dash (–) or em dash (—).

Same thing with “smart quotes”. Some applications (MS Word, HTML web pages) don't have quotes as in ASCII Decimal 34 values; instead they may have UNICODE left-quote and right-quote characters which the remote shell doesn't know how to understand. If you do a lot of copying command examples from other sources (like MS Word, or HTML web pages), you may want to configure SecureCRT to convert these upper ASCII (UNICODE) characters into their lower ASCII equivalents so that the remote shell will recognize them. This is done by setting the "Clipboard Format" in the Global.ini file found in SecureCRT's configuration folder to "VDS_TEXT", as described in the Advanced Copy & Paste in SecureCRT video found on the VanDykeSoftware You Tube Channel (specifically the content beginning around the 3:29 mark in the video).
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote