View Single Post
  #4  
Old 11-06-2009, 10:57 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 1,096
The "Local echo" option in SecureCRT affects SecureCRT's behavior only -- it does not result in any instructions for the remote to stop echoing data it receives. "Local echo" simply instructs SecureCRT to display characters typed immediately (whether or not the remote will echo them).

You'll need to turn off echo on the remote side in the specific way that it requires, either through an 'stty' setting in start-up scripts or some other mechanism.

If you don't somehow tell the remote to not echo data, you'll likely get characters doubled up when they're displayed -- once when they're typed, and again when the remote echo's them back to SecureCRT.

On many *NIX system varieties, the command 'stty -echo' turns off echo for the remote. You'll need figure out what's the best way to accomplish this on your remote system.

--Jake
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote