View Single Post
  #7  
Old 08-03-2005, 10:14 AM
jdev's Avatar
jdev jdev is offline
VanDyke Technical Support
 
Join Date: Nov 2003
Location: Albuquerque, NM
Posts: 926
Quote:
Originally Posted by jimserio
I'm trying to display ASCII characters through SCRT. TO my knowledge I have never been able to do this and I've tried every terminal type. I'm sure it's something simple but any help woudl be appreciated. Here's a screen shot of what I get with xterm with ANSI color as the terminal.
screenshot
jimserio,

I'm not sure if line drawing is still a problem for you or not, but the graphic you provided displays something that is indicative of line drawing problems that are caused by the Windows operating system treating a font as a Unicode font; notice how the corners of the boxes look right, but everything else seems to be off -- line drawing characters, yes. But not the right ones.

There are a couple of possible resolutions to this problem. One involves a configuration change in Windows, the other involves a configuration change in SecureCRT.

Disabling support for East Asian languages:
When you see line drawing as displayed in the screen shot you provided, it is typically caused by the "Install files for East Asian languages" option being enabled within the "Languages" tab of the "Regional and Language Options" window accessible from the control panel. When this option is enabled, the operating system seems to change how it addresses fonts. From what I can tell, it treats all fonts as Unicode fonts, and since Terminal and vt100 fonts aren't, it displays things wrong when it comes to 8-bit characters such as line drawing glyphs. Disabling the "Install files for East Asian languages" option (might require a machine reboot) should resolve the problem. Sometimes this option is enabled unbeknownst to a user as a result of choosing "Yes" to a prompt you might see browsing a web page that states something along the lines of "In order to view this page properly, fonts must be installed. Do you want to install these fonts now?".

Changing the configuration of SecureCRT:
If you depend on the ability to view East Asian languages and cannot disable this setting, there is a combination of SecureCRT configuration settings that should get line drawing to work properly even with this option enabled. In this case, open the Session Options dialog and in the Appearance category:
  • Ensure that the Use Unicode line drawing characters option is enabled.
  • Set the Font to a TrueType or OpenType font such as Courier New or Lucida Console.

In most cases, if the font is a TrueType or OpenType font (in the Font dialog, this is indicated by an O or a TT icon to the left of the font name) and the Use Unicode line drawing characters option is enabled, line drawing should work well.

Do either of these configuration changes get you to the point where line drawing is working properly?
__________________
Jake Devenport
VanDyke Software
Technical Support
YouTube Channel: https://www.youtube.com/vandykesoftware
Email: support@vandyke.com
Web: https://www.vandyke.com/support
Reply With Quote